1

There are many RDP questions out there, none of the ones I've read up to now have the exact same problem.

I have:

A Dedicated server running Ubuntu 12.04LTS An installation of VirtualBox with two instances of Windows 7

In order to RDP to the virtualised OS's I need to set the adapter to bridged, I have read that on so many tutorials & supprt sites etc.

When i do this, according to tutorials, the IP address should be assigned within the same range as the server and then I can RDP to the VM... .. this doesnt work for me.

Do i need to forward the SERVER-IP:PORT to the VM-IP:PORT to be able to access RDP ?

Do i need to alter the /etc/network/interfaces ?

or could it be due to DHCP ?

Update:

I've not configured anything on the Ubuntu Dedicated Server as of yet, but I have tried all types of 'Attached To' adapters in VirtualBox.

I don't know if this is relevant at all, but when i edit the VM only NAT ( adapter type ) seems to have the ability to access internet. All other ( including Bridged ) fail to connect to internet ( but cannot be pinged from the Ubuntu Server ).

I have to be honest here, this is the FIRST time i've tried to set this up, and in all the guides and tutorials, when selecting 'Bridged Adapter', it should just work. This is a head scratcher for me !

UPDATE :

It appears that RDP gets only as far as the Ubuntu xrdp service. I stopped it Now need to route the RDP traffic to the VM ( i think ) ....

TO CLOSE:

The server IP Tables were not being updated by ufw, a 'fasthosts feature' is that they use a different location for the firewall, once i had opened the ports and forwarded them the connection was allowed. Also for anyone else in this perdicament, I hope this helps !

Regards ;)

  • What are you trying to achieve?. Connect to the Windows 7 RDP server (shared desktop) or connect to the VirtualBox RDP server?. There are two different servers here and this is confusing. – Javier Rivera Aug 14 '14 at 11:03
  • I want to connect to the shared desktop, but from an external computer. – Deano Aug 14 '14 at 11:13
  • @JavierRivera - I take it my intensions with this are normal, and achievable ? – Deano Aug 14 '14 at 12:29
1

When you access a VM with RDP, its IP adress can be anything. I suspect you tried to connect to the VM instead of host.

In your RDP client, you must enter:

dedicated_host_name_or_IP:RDP_port_number_of_the_VM

for instance:

localhost:5001 # if I connect a VM running on my Virtual Box server.

192.168.1.25:5000 # IP adress of my dedicated server not of the VM.

Edit

There are two ways to use RDP on your VMs:

  1. Using the host machine as the RDP server. It works only if you activate the "Remote Display" server in your VMs setting (chapter Display). Using this will work even if your VM network configuration is incorrect.
  2. Using the VM itself as RDP server (I suspect it's what your trying to do). Then, you have to configure the TCP/IP options in the VM, not only the Virtual Box settings. Maybe you use the default DHCP option there. If this don't work with the bridged adapter setting (and works with the NAT), try this:

In the VB settings, make sure your bridged adapter is linked to your main interface (the one giving access to Internet to the VB host). Open the "Advanced options" and enable "Cable connected".

In the TCP/IP settings of the VM, choose DHCP. Restart the connection if needed.

If this don't work, open a terminal in the VM and type ipconfig to know if your VM got a working IP address.

|improve this answer|||||
  • Thanks for your reply: I have tried to connect to the Ubuntu Dedicated Server IP in order to connect to the Win7 VM using a Windows RDP client. I'll update the question to highlight what i've tried. – Deano Aug 14 '14 at 8:38
  • I have a static IP on the server. VM setup : Bridged Adapter [eth0] - Cable Connected - IP:169.254.111.201 - Sub:255.255.0.0... As in method 1, I enabled rdp server on virtualbox, i'm given 3 types of auth modes: null, external, guest - i chose NULL. on the VM itself, i enable Remote Connection. yet still cannot RDP to the instance of win7. method 2 has the exact same problem. – Deano Aug 14 '14 at 11:07
  • Firewall problem ? Did you tried to connect from the VB host itself ? And what's the result of ipconfig on the VM ? – Pyrophorus Aug 14 '14 at 11:29
  • ipconfig results are in the above comment :) recomendation for a ubuntu RDP client ? – Deano Aug 14 '14 at 11:32
  • Sorry, I thought it was the server adress. Is this one valid on your LAN ? Remote Desktop Viewer comes with Ubuntu I think. Remmina is fine too. – Pyrophorus Aug 14 '14 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.