1

I am a Linux novice and do not understand quite what is happening. The update manager in my 12.04 installation offered me the upgrade to 14.04 which I decided to do. So I clicked on the link and all seemed well for almost 3 hours. During the 'Upgrade packages' stage my system crashed and powered off without shutting down.

I have tried everything I can think off to get back in to my Ubuntu system including the dpkg recovery for the new version, boot to old version, dpkg recovery for the old version, and even using my original dvd that I saved the image onto for the first install of 12.04. Nothing is giving me access to my system so that I can repair it and get back to work though.

Is there a page somewhere in the help pages that I have missed on what my next steps should be? If I created a bootable usb drive copy of 14.04 would that help, and if so how can I do this?

At The moment I cannot access any of my data which I need to run my business and this is stopping me from working, costing me customers, and money is pouring down the drain. Please help soon as I am desperate.

  • Can you not access the hard disk from the live environment of the install DVD? – Wilf Aug 13 '14 at 20:22
  • Are you able to boot into recovery mode via the GRUB menu? – Pranav Marathe Aug 13 '14 at 20:22
  • I can access the hard drive and view the contents, but anything I do when I am using the Dvd is only temporary and no files are actually changed or moved. – Weedy101 Aug 13 '14 at 20:23
  • 1
    You should be able to mount your Ubuntu partition and recover all your data. – Pranav Marathe Aug 13 '14 at 20:29
  • 1
    If you can access the hard disk from a live environment or similar, you can and should backup the data. This means you still have it you need to reinstall, and is a safety net in case anything goes even more wrong whilst trying to finish the upgrade. If the data is important to your business, it should be backed up regularly. – Wilf Aug 13 '14 at 20:31
2

To attempt to complete the upgrade

  1. Boot into recovery mode
  2. Select the network option. Once that's done press enter to return to the recovery menu.
  3. Select the dpkg option. Again, when it's done press enter to return to the recovery menu.
  4. Select the root option and type in do-release-upgrade and then apt-get update && apt-get upgrade && apt-get dist-upgrade
  5. Reboot : sudo reboot

To backup your data

  1. Boot into a live cd
  2. Open gparted either via the command-line :sudo gparted & or from the dash.
  3. Figure out the name of your Ubuntu partition. (Should be in the format /dev/sdXY where X is a letter and Y is the partition number)
  4. For the rest of this post, replace /dev/sdXY with whatever you found out in the previous step.
  5. Mount the partition in /mnt/ : sudo mount /dev/sdXY /mnt/
  6. If you're comfortable using the terminal, you can use the cp and mv commands to backup your data. Otherwise, proceed to step 7.
  7. Run : nautilus /mnt/home/*/ . This will open up every user's home directory in a different window.
  8. Now you can backup your files to wherever.
  • I have noted these steps down and will have to log out to give them a try. How ever the 'Network' option in the recovery menu normally just hangs and does not connect, but try this I will. Thank you. – Weedy101 Aug 13 '14 at 20:39
  • Just updated my post to include steps on how to backup your data. – Pranav Marathe Aug 13 '14 at 20:39
0

Thanks to all for your help. After following the steps laid out by @pranav I eventually figured out that the root of the problem was a package called 'ncurses-base' which dpkg was reporting as 'to inconsistent to configure'. I am guessing that this may be what caused the original upgrade process to crash.

I managed to borrow a copy of a linux based 'Kaspersky recovery disk' which ran from the cd but gave me a live file system, as the original installation disk only booted to a trial version which did not permit permanent changes and thus I could not copy my data to another drive. So I downloaded the Ubuntu 14.04 image and burnt it to disk. I then copied all of my data to an external drive.

Then in the install process I opted to erase the existing version and replace it.

The install went smoothly and although I have to install all the packages I was using again that is just a mater of time and all solved.

Once again thank you all for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.