0

Phone Status: Ubuntu touch was installed, but i have to reinstall it because the Ubuntu install is broken.

Im unable to install Ubuntu Touch/Phone a second time, it always errors out with the following output:

    $ sudo ubuntu-device-flash --channel=devel --bootstrap
    2014/08/13 20:41:23 Expecting the device to be in the bootloader... waiting
    2014/08/13 20:41:23 Device is |mako|
    2014/08/13 20:41:23 Flashing version 179 from devel channel and server https://system-image.ubuntu.com to device mako
    2014/08/13 20:41:23 ubuntu-touch/utopic is a channel alias to devel
    /home/k1773r/.cache/ubuntuimages/ubuntu-touch/devel/mako/version-179.tar.xz
    /home/k1773r/.cache/ubuntuimages/pool/device-97360477eff33a9f63eaf8d65b8bc174344963ee793f2eb99107a81bab62262d.tar.xz
    2014/08/13 20:42:46 Cannot cleanup /cache/recovery/ to ensure clean deploymentexit status 255

I did wipe the /cache partition with the "Ubuntu Touch Recovery". This didnt help, so i did it with fastboot. Unfortunately neither this solved my issue.

It is possible to reinstall Android, but not Ubuntu Touch.

While in Recovery, "adb devices" only spits out ? and "no permissions".

How can i solve this issue and get Ubuntu Touch running again?

  • Did you also try a different channel? (e.g. you could try trusty) – Kai Aug 13 '14 at 20:16
0

After locking + unlocking @ fastboot, getting root permissions @ android (su was missing), i was finally able to install ubuntu touch again.

When it booted to recovery, adb couldnt talk anymore to it, causing said error. Following the order above solved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.