77

I want user foo to auto-login using LightDM (which has been used by Ubuntu since version 11.10). How would I do that?

  • 4
    FYI, If you are using home folder encryption, you can't enable auto login. – Saeid Zebardast Mar 30 '13 at 8:37
  • I know its slightly off-topic: I want to mention nodm is an alternative option which can start an x session for a user on boot with no auth (thinks like the lock screen probably wont work, etc) – ThorSummoner Jun 24 '19 at 7:03

13 Answers 13

48

You can do this without editing configuration files: go to System Settings > User accounts, click "Unlock" and enter your password, then click the button next to "Automatic login":

'enter image description here

| improve this answer | |
  • 3
    I'm working on Ubuntu 14.04. Here there is no option as "Automatic Login" as shown in your screen shot. Please say how to enable automatic login. – Ravi Sep 25 '14 at 6:48
  • @Ravi: the option is still there in Ubuntu 14.04 and 14.10. But there's an alternative answer below for enabling this from the lightdm.conf file. – Alin Andrei Sep 26 '14 at 11:40
  • @Ravi do you have home folder encryption on? – jcollum Jul 26 '17 at 14:28
78

An alternative to Alin's answer is to create a file /etc/lightdm/lightdm.conf and add the following content:

[SeatDefaults]
autologin-user=<YOUR USER>
autologin-user-timeout=0
user-session=ubuntu
# Uncomment the following, if running Unity
#greeter-session=unity-greeter

Next time you start, auto-login should work like expected.

| improve this answer | |
  • 8
    Setting autologin-user to your user name is enough for autologin to work. – Smile4ever Oct 22 '14 at 16:47
  • 1
    On old versions there is a bug, if you set autologin-user-timeout=0 (or any other value to autologin-user-timeout), it's not working (LP#902852, debian#682473. – pevik Apr 23 '16 at 4:48
  • 1
    @Smile4ever for my setup (debian buster 4.18 + openbox) it didn't work without autologin-user-timeout=0. – Vorac Dec 15 '18 at 17:42
24

For Ubuntu 14.04 create the file:

/etc/lightdm/lightdm.conf.d/12-autologin.conf

and add:

[SeatDefaults]
autologin-user=youruser
| improve this answer | |
  • 1
    I had to create this file and all it had was this and worked! – Peter Oct 20 '14 at 12:39
  • 2
    This worked for me on 64-bit Ubuntu MATE 18.04 LTS (Bionic), as of July 2018, when editing /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf file like I did in 16.04 LTS, did no good. – ablaze Jul 7 '18 at 19:52
17

You can easily do this with lightdm-set-defaults if you'd rather not edit lightdm.conf manually:

sudo /usr/lib/lightdm/lightdm-set-defaults --autologin "$USER"

It will not set the autologin timeout, but the default for that is 0 in the code anyway, so you don't need to set it.

| improve this answer | |
  • 8
    This doesn't work in 14.04 LTS as lightdm-set-defaults was removed then so the other methods are better. – Robert Ancell Aug 22 '14 at 7:33
7
gksu gedit /etc/lightdm/lightdm.conf

add lines:

autologin-user=username
autologin-user-timeout=0

example:

[SeatDefaults]

user-session=ubuntu

greeter-session=unity-greeter

autologin-user=alan

autologin-user-timeout=0
| improve this answer | |
3

Open settings, select 'user accounts'. Click the unlock button, then change the Automatic Login switch to "On"

| improve this answer | |
  • 1
    Thank you Luyang Liu, but this optino is not displayed in User Accounts. – Agmenor Jan 17 '13 at 18:34
2

In Ubuntu 18.04 (Xubuntu Minimal Desktop), create /etc/lightdm/lightdm.conf and add the following:

# /etc/lightdm/lightdm.conf
[SeatDefaults]
autologin-user=<username>
autologin-user-timeout=0

I couldn't get it working through the lightdm.conf.d folder.

| improve this answer | |
  • Worked on 16.04 as well. – IsaacS Mar 14 '19 at 4:24
1

Search for "User Accounts" application. Select the account you want to autologin Toggle the Automatic Login switch to On

That should do the work.

| improve this answer | |
1

I can confirm that this works for 16.04.
Using your favourite editor, amend /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf.
Add autologin-user=xxxx to the file, for example:

[Seat:*]
greeter-session=lightdm-gtk-greeter
autologin-user=wmurphy

Remember to also set the Not asked to login option under Users and Groups.

| improve this answer | |
0

I have 12.10 xubuntu. In users and groups choose your user, and click word "Change..." next to "Password:" (it does not look like a button, what might be a bit misleading). There you can change password, or at the bottom mark "Don't ask for password on login" box.

Hope it works.

| improve this answer | |
  • Thank you very much Chris. However, as explained in my question, this solution is not displayed in User Accounts. – Agmenor Jan 17 '13 at 18:34
0

I just discovered that, I need to have ubuntu-desktop to be install before lightdm could function. This solved my issue when trying to get lightdm to actually login in without going in loop.

The reason for the system to go in loop may be because lightdm needs the ubuntu desktop before it may work.

sudo apt-get install ubuntu-desktop
| improve this answer | |
  • This is absolutely wrong, since I'm using lightdm with openbox environment only – Patrizio Bertoni Sep 19 '17 at 14:54
  • Can you point to a link for how to do this? I had set lightdm.conf user-session=LXDE, then switched that to openbox as per /usr/share/xessions/openbox.desktop, but it keeps starting LXDE. – naasking Sep 4 '18 at 11:40
0

I had the same problem, I solved it with the following steps:

  1. login as root: sudo su
  2. enter the file:

    sudo nano /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
    
  3. at the bottom add:

    autologin-user=xxxx
    
  4. save the content of the file then exit and reboot.

This should definitely work.

| improve this answer | |
0

Ubuntu 20.04 How To: automatic login of particular user (e.g. server login)

autologin for Ubuntu 20.04 and Ubuntu 20.04 LTS with XFCE4 this works:

(all as root using sudo)

0) set display manager to lightdm

dpkg-reconfigure lightdm

check settings with

lightdm --show-config

1) enable login without password

under Users and Groups

set the Not asked login option for the concerned user.

2) create and edit a new file /etc/lightdm/lightdm.conf.d/01_username.conf

vim /etc/lightdm/lightdm.conf.d/01_username.conf

and set

[SeatDefaults]
autologin-user=username
autologin-user-timeout=0

replace "username" according; do NOT set autologin-user-timeout other than 0, does not work!

This solution worked fine with a nearly vanilla installation without gnome and without unity.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.