0

I have a wifi USB dongle which I have previously used on a Raspberry Pi (this it is what it is target at).

I am trying to get it working on an Nvidia Jetson TK1, however I am having some problems.

When I run ifconfig I can't see the wifi, only the ethernet and local loopback.

iwconfig reports no wireless extensions on all devices.

lsusb does find the device:

Bus 002 Device 008: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

So I am not sure why the network tools can't see it.

I have tried logging on with a GUI and opening up the network settings through Unity, but cannot see any wireless devices either.

Not sure if this is useful, but output of lsmod:

Module                  Size  Used by
nvhost_vi               2940  0

How can I enable wireless networking on this computer?

Command line approach is preferred, but either is fine.

UPDATE

I don't have the kernel module rt2800usb anywhere on my system. If I do an apt-file search for rt2800usb it lists a number of packages of the pattern: linux-image-3.13.0-*.

Perhaps installing one of these will do the trick, but can anyone tell me if its safe to do so?

3
  • Is that Raling or Ralink? Ralink drivers have to be compiled from source, iirc. – muru Aug 13 '14 at 10:18
  • Ralink (corrected). Are you sure? I haven't had to do this in Raspbian. – Alex Aug 13 '14 at 10:20
  • askubuntu.com/questions/99373/… I had to, every time I faced an Ralink device in the past year (usually laptop cards). – muru Aug 13 '14 at 10:24
1

That device is covered by rt2800usb in newer Ubuntu versions. Check:

modinfo rt2800usb | grep 5370

You should see this:

alias:          usb:vF201p5370d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp5370d*dc*dsc*dp*ic*isc*ip*in*

If you do, load the module and see if the wireless comes to life:

sudo modprobe rt2800usb

Get the module to load automagically on boot:

sudo -i
echo rt2800usb  >>  /etc/modules
exit

If your Ubuntu version is older, I suggest you upgrade. It will probably be easier than compiling from Ralink's source code.

4
  • I get ERROR: Module rt2800usb not found. Might be a problem! Is there a package I can install to get this? – Alex Aug 14 '14 at 8:12
  • What Ubuntu version are you running? uname -r and also: lsb_release -d Thanks. – chili555 Aug 14 '14 at 12:14
  • uname -r gives: 3.10.24-g6a2d13a, and lsb_release gives: Ubuntu 14.04.1 LTS. Cheers. – Alex Aug 20 '14 at 9:39
  • It is safe to install the later 3.13 kernel which will give you rt2800usb and drive your device. If there is an 'extras' package along with the linux-image, be sure to install it, too. – chili555 Aug 20 '14 at 13:05
0

Flashing the Jetson with The Grinch got my Ralink USB modem working. The instructions may be found here: The Grinch 19.3.6 for Jetson TK1

You will need at least 15 Gig available on the host computer for the procedure to work.

I chose this option because of the long list of kernel improvements listed.

0
  1. Check the kernel version of Jetson TK1 by using command uname –r
  2. Go to the website, based on kernel version of Jetson TK1, select the respective Linux kernel backports to download.
  3. After completed download, extract the backports folder.
  4. Type command make
  5. Type command sudo make install
  6. Type command sudo reboot
  7. Plug in USB WiFi dongle and now you should see your USB WiFi dongle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.