3

Using the Launcher to open Chrome (Super, chrome, enter) does not take focus from what ever application was running previously.

Kinda defeating the purpose of the Launcher.

At the same time, the text cursor is 'alive'/blinking in both chrome in the search bar and any previous application.

Is there is a setting to force Ubuntu to move focus on opening a new application?

Note: I am using multiple desktops and 2 monitors if that is relevant

  • 1
    It is chromium-webbrowser, right? is it only with chromium? – Jacob Vlijm Aug 13 '14 at 9:32
  • Yes, only with chromium-webbrowser, other programs take focus as expected – D3L Aug 13 '14 at 9:59
  • updated script; there were a few errors. – Jacob Vlijm Aug 13 '14 at 11:11
  • I am using Google Chrome in just one monitor and I have the same problem. – Waldir Leoncio May 5 '16 at 23:13
3

Running dconf and setting org.gnome.desktop.wm.preferences auto-raise to true will do the same thing.

or on commandline:

gsettings set org.gnome.desktop.wm.preferences auto-raise true

This is helpful if you dont want to install compiz

1

Try the solution at http://ubuntuforums.org/showthread.php?t=1857163. It basically requires accessing CCSM (CompizConfig Settings Manager) and setting "Focus Prevention Level" in General Options to "None".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.