Occasionally, my Conky window jumps to the top and covers all other windows. The only way to solve it is to kill and restart Conky.

This happens at seemingly random times while using Compiz features. It seems especially common while using the scale plugin's window picker, but no plugin consistently causes this problem every time.

I've seen several questions that appear related on the surface. However, all those questions are solved by ensuring that Conky starts after Compiz. In my case, my problems occur even if Conky starts after Compiz.

Here's my ~/.conkyrc:

# Conky settings #
background no
update_interval 1

cpu_avg_samples 2
net_avg_samples 2

override_utf8_locale yes

double_buffer yes
no_buffers yes

text_buffer_size 2048
#imlib_cache_size 0

temperature_unit fahrenheit

# Window specifications #

own_window yes
own_window_type override
own_window_transparent yes
own_window_hints undecorate,sticky,skip_taskbar,skip_pager,below

border_inner_margin 0
border_outer_margin 0

minimum_size 200 250
maximum_width 200

alignment tr
gap_x 5
gap_y 20

# Graphics settings #
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no

# Text settings #
use_xft yes
xftfont ubuntu:size=8
xftalpha 0.5

uppercase no

temperature_unit celsius

default_color FFFFFF

# Lua Load  #
lua_load ~/.lua/scripts/clock_rings.lua
lua_draw_hook_pre clock_rings

  • 2
    is this already on your conky file ? paste.ubuntu.com/634888 – Uri Herrera Jun 29 '11 at 9:00
  • @Uri: As you can see in my .conkyrc (which I forgot to post earlier, I'm using the override type. This works fine on my other Natty computer, so I can't see how it could be the problem. – Scott Severance Jun 29 '11 at 11:43

So far, Uri Herrera's answer (left in a comment on my question) is working for me.

Note to mods: I previously posted this answer, but it was deleted as not an answer, and there's no way to discuss that deletion. I'm re-posting it because this is the best answer given. The mod said that it's really a comment, not an answer, but he's mistaken. Uri posted his answer in a comment; thus, I can't accept it. So, I posted a reference as an answer and was waiting for the timeout to expire so that I could accept it. (Why do I have to wait 24 hours before accepting my own answer?) Since I can't move Uri's answer from a comment to an answer, there's no other way than what I've done.


It's been a while since I've tweaked conky, so please excuse if this does not work.

Have you tried replacing override with desktop, and commenting the own_window_hints line?

But I believe you need Nautilus to be the desktop agent for this to work.


In my case problem was solved by running this script at startup:

sleep 30 && conky;
  • Note that yours is an unrelated problem, as I pointed out in my original question (now solved) that my problem occurred regardless of when conky started. – Scott Severance Sep 19 '11 at 4:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.