3

I'm currently trying to set up samba, and upon creating my first share, it asked if I wanted to set permissions automatically, and I said yes, and then I got an error saying "Could not change the permissions of folder 'Network'"

Is there something I did wrong? It's a whole hard drive that I'm trying to share. The format is exFAT, and it's been set up to mount automatically.

2
  1. Connect and mount the drive to the Ubuntu computer. The format of the drive doesn't seem to matter.

  2. DO NOT right-click on the drive and go into the sharing options via the drive’s properties. This will not work.

  3. Make sure you have Samba installed. (You can find it in the Ubuntu Software Centre titled “SMB/CIFS file, print, and login server for Unix”)

  4. Install, if you haven’t already, install the Samba GUI. (Also in the Ubuntu Software Centre titled “Samba” with a description of “Create, modify, and delete samba shares”.)

  5. Run the Samba GUI. Search the dash for samba.

  6. File|Add Share

  7. Browse for the drive you wish to share and select it

  8. Change the share name if you’d like to. (For this example my share name is “AlpahHD″)

  9. Check “Writeable” if you wish to be able to write to this drive from other computers on the network.

  10. Check “Visible” if you’d like others to see the share while browsing the network.

  11. On the Access tab, select “Allow access to everyone” (This will avoid the problems of having to specify usernames and passwords in programs like XMBC and MediaPortal.)

  12. Click OK (You should be done at this point but you’re not. This is what caused me the most headaches to find.)

  13. Open a Terminal session (Ctrl+Alt+T)

    cd /etc/samba
    sudo gedit smb.conf
    

    (Feel free to use the editor of your choice. I like Gedit.)

  14. Scroll to the bottom of the file. There you should find [AlpahHD] (remember that’s the name of the share I created.)

  15. Add the following new line in that section:

    force user = username 
    

    (In my case username is “tim” since that’s the username I log in to Ubuntu with. Replace with your username.)

  16. Save the edited file.

  17. Restart Samba sudo restart smbd

You should now be able to access the shared drive from any Windows computer on your network.

Source

| improve this answer | |
  • Will accept this answer in 5 minutes, because I'm not allowed yet. Thank you! – Cody Aug 12 '14 at 21:48
  • 1
    Pleasure! That is one of the first Ubuntu articles I bookmarked - it worked perfectly for me! – Tim Aug 12 '14 at 21:49
  • Yeah, it works great! Now I just have to figure out the IP to connect to. – Cody Aug 12 '14 at 21:57
  • Hey @Tim, any idea about setting permissions for windows users? I can't delete or rename anything when I'm on my Windows account. – Cody Aug 12 '14 at 22:07
  • change the line read only = yes to read only = no in smb.conf – Tim Aug 12 '14 at 22:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.