1

I am trying to build banshee but I can't get it to compile. I used the banshee Source Tarball, and the banshee github code.

Here is a script on what I already did:

#!/bin/bash

# dependencies

sudo apt-get install aptitude
sudo aptitude build-dep banshee

sudo apt-get install git-core autoconf p7zip-full automake libtool intltool gcc make libgconf2.0-cil-dev libgconf2-dev boo libboo-cil-dev mono-gmcs libglib2.0-cil-dev libgstreamer1.0-dev gstreamer-1.0 libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev gtk-sharp2-gapi libdbus-glib1.0-cil-dev libmono-addins-cil-dev libgudev3.0-cil sqlite3 libsqlite3-dev libdbus-glib-1-dev libmtp-dev libgpod-cil-dev libmono-zeroconf-cil-dev libgtk-3-dev monodevelop libgudev3.0-cil* 

#downloading 
# wget http://ftp.gnome.org/pub/GNOME/sources/banshee/2.9/banshee-2.9.1.tar.xz
# 7z x banshee-2.9.1.tar.xz
# 7z x banshee-2.9.1.tar
git clone git://github.com/GNOME/banshee.git
cd banshee

#dependencies: PASSED 
git clone git://github.com/mono/gtk-sharp.git
cd gtk-sharp
./autogen.sh
make
sudo make install 
cd ..

# gstreamer-sharp-1.0: PASSED 
git clone git://github.com/inizan-yannick/gstreamer-sharp-1.0.git
cd gstreamer-sharp-1.0
./autogen.sh
make
sudo make install 
cd ..

# taglib-sharp: PASSED 
git clone git://github.com/mono/taglib-sharp.git
cd taglib-sharp
./autogen.sh 
make
sudo make install
cd ..

# configuring, make and installing banshee
./configure
make
sudo make install

At this time I get the following error, when I make banshee.

error CS0006: Metadata file `/usr/local/lib/cli/gstreamer-sharp-1.0/gstreamer-sharp.dll' could not be found

But the configure;make;sudo make install of gstreamer-sharp-1.0 PASSED without any issues.

4
  • It shouldn't be looking for a dll, it should be looking for a .so. – RobotHumans Aug 12 '14 at 19:52
  • 1
    @hbdgaf, banshee uses mono. Mono names stuff .dll. – blade19899 Aug 12 '14 at 19:53
  • Did you succeed? – Steven Roose Jun 2 '15 at 23:20
  • 1
    @StevenRoose No. I gave up. Not worth the time and effort. At least not for me. – blade19899 Jun 3 '15 at 7:50
0

The repository you're using for gstreamer-sharp is wrong, it should be git://anongit.freedesktop.org/gstreamer/gstreamer-sharp instead (and checkout the tag 0.99.0 after you clone).

Also, I've seen some distros fail to load assemblies located in /usr/local, then you may want to try to fix this problem by using the /usr prefix (passing it in the configuration phase: ./autogen.sh --prefix=/usr).

6
  • I sudo make uninstall everything. Tried the repo you suggested, and used the --prefix=/usr flag u suggested but, when make banshee i still get the aforementioned error? – blade19899 Aug 13 '14 at 14:44
  • that is certainly weird, what does the gstreamer-1.0.pc file contain? – knocte Aug 13 '14 at 16:30
  • oh, and you need to ./configure again, not just make – knocte Aug 13 '14 at 16:31
  • I did that. I sudo make uninstall and ./configure;make;sudo make install.. on make it gives the error.... – blade19899 Aug 13 '14 at 17:37
  • what does your gstreamer-1.0.pc file contain? – knocte Aug 13 '14 at 17:53
0

I tried to compile it by myself with no go results. Nevertheless I did a search and had came with the page: banshee Download (DEB, RPM, TXZ, XZ)

There I found banshee_2.9.0+really2.6.2-2ubuntu2.1_amd64.deb, not a direct answer but, in my case, Amazon Player was safe and sound (not working before) as well (not problematic) the other plugins. I found this a much easier approach. I´ll continue to solve the compilation issue you mentioned above

3
  • I installed the package, and it's still the same version(2.6.2) Even after a reboot? – blade19899 Aug 29 '14 at 12:06
  • banshee_2.9.0+really2.6.2-2ubuntu2.1_amd64.deb Description banshee - Media Management and Playback application Distribution: Ubuntu 14.04 LTS Repository: Ubuntu Proposed Universe amd64 Package name: banshee Package version: 2.9.0 Package architecture: amd64 Package type: deb Installed size: 13,51 KB Download size: 2,60 MB Binary package: banshee_2.9.0+really2.6.2-2ubuntu2.1_amd64.deb Source package: banshee – jglerner Aug 29 '14 at 20:09
  • It says 2.9.0 + really 2.6.2. Is that a massive troll? Is it really just 2.6.2? – Steven Roose Jun 2 '15 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.