I regularly switch between 3 scripts (English/Roman, Kannada and Hindi/Sanskrit/Devanagari).

In 12.04, I used to enable IBus by typing Ctrl+Space to switch from English to Kannada, and again the same key to switch back to English. If I wanted to move to the next input method, I used to press Alt+Left Shift.

Now I have upgraded to 14.04. Here I see the option to move to the next and previous input method. However, I don't see any option to disable the input method completely and use the default (English) script.

So, If I have to switch from English to Kannada, I have to press Ctrl+Space, and then from Kannada to English, I have to either press Ctrl+Space twice, or Ctrl+Shift+Space

Is there any way to just enable/disable the IBus input just like it was in 12.04?

1 Answer 1


Go to Language Support and Locate Keyboard input Method System and change it from Ibus to None.

Language Support

  • @techtonic : Why did you edit this answer after receiving my answer on your question askubuntu.com/questions/668388/… ? Does this mean that it worked for you ? If yes, I think it would be fair enough to accept / upvote my answer !
    – cl-netbox
    Sep 2, 2015 at 12:37
  • @cl-netbox, probably I didn't see your answer while adding a picture here. Disabling IBus didn't help - it just disabled language switching support, and I haven't found a way to switch languages without IBus. How should it work without IBus? Sep 2, 2015 at 13:29
  • @techtonic : Thanks! That's the elegant solution I was looking for. IBus conflicts with the default keyboard manager in Ubuntu 20.10 (using Cinnamon Desktop). The whole DE is slowing down by that conflict. After selecting "none", I can now use the defaut keyboard manager and Cinnamon become very responsive! Took me days to find that one
    – Gael
    Dec 9, 2020 at 3:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .