0

I upgraded my server to 14.04.1. After I restarted Apache, I discovered that some of my sites are not accessible (403 forbidden). The common denominator is that they are my Drupal sites and a group of Wordpress (multisite) sites. A pair of other WP (multisite) sites in a separate directory are working.

If I type the base URL as an IP address, e.g., 66.210.xxx.xx, in my browser, I get a DB error: I cannot connect to the database because: Access denied for user 'root'@'localhost' (using password: YES)

It's a LAMP VM, hosted remotely, so I only have SSH access. I did turn off root access with password over SSH when I did the package upgrade; don't know if that's related. I don't login as root, so I didn't think I needed it.

The other noteworthy thing is that before I could start Apache, I had to edit my v-hosts.conf files, because they had this:

<Directory "/path/to/site">
    allow from all
    Options -Indexes FollowSymLinks
    AllowOverride All
</Directory>

I had to change the Options to:

Options -Indexes +FollowSymLinks

In order to restart Apache.

1

After checking the logs, looking at directory permissions, making sure various DMS db configs hadn't changed, etc, I looked at /etc/apache2/apache2.conf, which apparently I had allowed to be overwritten during the upgrade. The <Directory> sections are more restrictive than what I had, since I have different CMSs in non-standard locations, NOT /var/www/. Those were the sites that wouldn't let me in. Adding in directives for them (and using the new "Require all granted" syntax) & restarting Apache solved it.

1
  • Could you please add more details on the points? – Anwar Dec 24 '16 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.