A new Ubuntu user here. I just installed Ubuntu 14.04 on my gigabyte U24F laptop. At first the touch-pad (I believe it's elantech) was working fine but one day I turned it off using fn+f10 key from the keyboard. The next day I could no longer turn it back on and it has since been undetected by the system.

xinput returns

Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Video Bus                                 id=9    [slave  keyboard (3)]
    ↳ Power Button                              id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

so there's no touch-pad detected. I'm using a USB mouse at the moment.

Attempting to run synclient gives

"Couldn't find synaptics properties. No synaptics driver loaded?"

Things I've tried so far to no avail

  • Reinstalling xserver-xorg-input-synaptics.
  • Checking dconf.editor settings, touchpad is enabled.
  • Booting into a live usb session, touchpad no longer even works in this case. (Does this mean a fresh install wouldn't even solve the problem?)

Any help is greatly appreciated!


Try the following

cat /proc/bus/input/devices | grep Name

Output should include > Elantech Touchpad

If so download the following


Open a terminal, and follow these steps

cd ~/Downloads sudo dkms ldtarball psmouse-elantech-x551c.tar.gz sudo dkms install -m psmouse -v elantech-x551c

sudo rmmod psmouse sudo modprobe psmouse



  • Hi, thanks for your answer! I have tried 'cat /proc/bus/input/devices | grep Name' Output: link There's no device named Elantech Touchpad or anything like a touch pad. I also followed the rest of the steps but nothing changed. Could it be that the key fn+f10 used to turn on and off the touchpad is conflicting with something in ubuntu? – user314973 Aug 13 '14 at 15:38
  • Not too sure about the fn+f10 comb, almost looks like the touchpad is not getting loaded. Try the suggestions from this link. askubuntu.com/questions/237059/… or this suggestions from this link askubuntu.com/questions/256106/… – Mahendra Gunawardena Aug 13 '14 at 18:07
  • Thanks. I tried them but they don't work for me. I think my problem is different. My touchpad is not even detected in my devices list. The solutions above are for the case where it is (wrongly) detected as a psmouse. – user314973 Aug 14 '14 at 2:47
  • There are three similar thread, with similar symptoms, there could be a bug. Might want to log a bug report. Here is a link. wiki.ubuntu.com/DebuggingTouchpadDetection – Mahendra Gunawardena Aug 14 '14 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.