16

I want to download free Google books in pdf format.

Is there any Google Books downloading tool available for Ubuntu?

  • 1
    duplicate question , maybe this answer could help askubuntu.com/questions/339927/download-google-books – Hany Alsamman Aug 12 '14 at 15:07
  • 2
    @HanyAlsamman Not exact duplicate because I clarified "downloader" and however askubuntu.com/q/339927 is closed as unclear! – APLUS Aug 12 '14 at 15:11
  • 1
    check this tutorial pc-freak.net/blog/… – Hany Alsamman Aug 12 '14 at 15:27
  • 3
    Two other solutions I found a while ago: pysheng and getxbook. I would write a proper answer but I've never tried these out. So if you feel up to task, please feel free to include these tools in your own post. – Glutanimate Aug 12 '14 at 19:33
  • @HanyAlsamman that answer doesn't come close to answering this OP's question. and the tutorial you've linked to has a downloader that works only on windows and mac OSes. – dbliss Aug 10 '15 at 4:01
9

There is a Python program called PySheng than did the job for me.

It's available on Github at https://github.com/tokland/pysheng

You can run the following commands to install it.

git clone https://github.com/tokland/pysheng
cd pysheng
sudo python setup.py install

Now PySheng will be available from the Termainl.

You can run pysheng-gui and pysheng from the terminal for the GUI and terminal version respectively.

pysheng-gui

PySheng GUI for downloading from Google Books

  • According to pysheng/readme.md, the correct command for installation (and the one that worked for me) is sudo python setup.py install. - I have edited accordingly. – user47206 Oct 12 '16 at 11:41
  • It is installed by default in the home directory. But then it can be moved anywhere and launched by executing /pysheng/bin/pysheng-gui. Path to that could be added into a launcher (desktop file) put in ~/.local/share/applications. – user47206 Oct 12 '16 at 12:01
  • import gtk.glade ImportError: No module named glade Its giving this error. I tried to follow the steps in git hub but I am unable to find /usr/share/pysheng/main.glade in line 362. In fact in the whole script there is no such line. – Hirak Apr 5 '17 at 21:07
  • @Hirak Try this: sudo apt-get install git python-appindicator python-xdg python-pexpect python-gconf python-gtk2 python-glade2 libxxf86vm1 – supremum Nov 27 '18 at 5:07
7

Thanks to @Glutanimate for his comment to the OP.

getxbook makes a good case for why it is the best option available. I just installed it and used it to download this book with success.

getxbook comes with installation instructions (in the INSTALL file). Once installed, it is run as follows:

$ getxbookgui

Alternatively, the command

$ getgbook book-id

can be used. (The book ID is in the URL for the book. For example, the ID for the book I downloaded is 3pK1-LxtFV4C.)

If only a subset of pages is desired, use

$ getgbook -n book-id

And then enter the pages you want, one at a time, e.g.:

$ getgbook -n book-id
262

When I said the book was downloaded with success, I wasn't being totally honest. For some reason, getxbook missed a few pages that were available in the preview. To get these, I followed these instructions.

Note that the book is downloaded to a sub-directory of the current directory named with the book ID. It is downloaded as a set of .png and/or .jpg files, one per page. These can be converted to .pdf format as follows (after converting the .jpg files to .png files one by one):

$ convert *.png book.pdf

Note that if you intend to print this .pdf on paper, you may need to resize some of the individual images (so that they're all roughly the same size) before converting to the .pdf. I used gimp to do this.

  • make: *** No rule to make target 'util.h', needed by 'getgbook.o'. Stop. PySheng worked for me instead. – Max N Aug 10 '17 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.