2

I run Ubuntu 12.04 in VirtualBox 4.3.14 on Windows 7 with a Swedish keyboard layout. In Windows everything works fine but in Ubuntu some keys/characters (the most important for a programmer) doesn't work.

This is the result from pressing the keys in the top row

1234567890+´   (Unmodified top row on keyboard)
 @£$€ {[]}\    (Windows with AltGr)
¡ £$€¥     ±   (Ubuntu with "AltGr")

More characters are broken (pipe | is a notable example) but the top row is the biggest problem. I can workaround this by enabling "direct connection" from my USB keyboard to VirtualBox but then I have to manually disable that every time I switch out of VirtualBox.

I have tried different keyboard layout, sometimes @ et al works but then other characters are broken. I also tried sudo dpkg-reconfigure keyboard-configuration with default values, but it didn't change anything.

I have guest additions installed (from the built in virtual CD). I got my VB disk image from a colleague who does not have this problem, however, he does not have guest additions installed (and hence can't use a higher resolution than 1024x768, and I need to run Eclipse...). He also have different installation of Virtual Box and Windows.

For example, the key for 2 should, in Ubuntu, produce four different characters, 2"²@. The first three works fine, including superscript 2 that requires AltGr-Shift-2, it is just plain AltGr-2 to get @ that does not work on this key (and all the other keys I have problem with).

Any ideas for a fix?

-1

I have the very same problem with a guest xubuntu and host window 7. I reinstall guest additions and I get the Altgr+2 working and lost left-arrow. I lost my patience and I have created another VM. The only difference was the Type of it, this time I have chosen type: "Linux" instead "Other". The keyboard is working as expected.

  • As the person who asked the original question I don't agree with you. If the suggestion works, then it is an answer that I am satisfied with. Unfortunately I can't test it at the moment (and can mark it as an solution) and I don't have the reputation to vote up. However, you should remove your downvote. – d-b Aug 26 '14 at 8:27
0

I have had the same problem and the solution after a great headache during days has been the following. Nothing can be more easy: In the option: file->preferences->input the following check box must be disabled: keyboard autocapture

I am translating from spanish version, but there must be something similar in the english version. Greetings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.