12

I have been trying to connect my new Boogie Board sync to a virtualbox 4.3 virtual machine running on an ubuntu 14.04 host. I keep running into this NS_ERROR_FAILURE (0x80004005) and have not been able to resolve it, despite trying it a number of different ways.

Note I did look up a few different existing posts, but they did not help. The issues are different than the one that I am running into and the software versions are different too. But here are the ones I looked at.

Virtualbox does not run: NS_ERROR_FAILURE

What is holding my USB device when I try to use it in VirtualBox?

The error message I get says

Failed to attach the USB device Improv Electronics Sync [0120] to the virtual machine        
IE11 - Win8.1_1. Failed to create a proxy device for the USB device. (Error:     
VERR_READ_ERROR).

The message details indicate

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

Note I am using the Windows 8.1 virtual machine from Microsoft, but I don't believe that makes any difference.

Things I have tried:

  1. enabled USB controller on the virtualbox manager with the EHCI controller.
  2. tried enabled USB controller without the EHCI controller.
  3. tried to rebuild the virtualbox image from scratch.
  4. added myself to the vboxusers group.

None of this has seemed to work.

Any suggestions?

2

4 Answers 4

2

USB devices can either be used on your host OS or guest OS, but not shared between both. Whatever captures the USB device first, will block communication for the other system.

You should have the VirtualBox extensions pack installed, which enables USB 2.

Then you need to install the VirtualBox guest additions in your virtual machine.

Next you need to start the VM, go into the machine settings and choose Ports/USB. Then select the + icon and add the USB device.

1

In case somebody bumps to this in the future. It may be that the required packages are not among dependencies. In my case, running through the terminal throws:

WARNING: The character device /dev/vboxdrv does not exist.

Installing virtualbox-dkms solved my problem.

sudo apt-get install virtualbox-dkms
4
0

The most simple decision, that I found is to enter into the folder /home/$user/.VirtualBox/ find there file VirtualBox.xml-prev delete VirtualBox.xml and change name VirtualBox.xml-prev on VirtualBox.xml. That backed up your configurations of Virtual Box.

1
  • thanks @Skynet , I tried to do this, but still no luck. I am still getting the same error. No change in the error specified either. The host device recognizes the usb device but I cannot get the virtualbox image to recognize it. I even tried reinstalling the virtualbox image a few times, but no luck.
    – krishnab
    Sep 10, 2014 at 2:12
0

I have replayed to similar question here.

A simple command can fix your problem:

sudo /etc/init.d/vboxdrv setup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.