I recently tried installing Ubuntu 14.04 on a new Asus VivoPC vm60 and it didn't work. The GRUB loader would abort with the message:

drm_kms_helper: panic occured...

I wasn't able to find any direct help regarding this so I thought I would post my question here.

4 Answers 4


If you want 14.04: BIOS -> WLAN -> Disable. This way you'll be able to boot and install Ubuntu.

After that, make sure to install all the available updates because newer kernels got added support to the wireless chip on board.

You don't need anything else to do: just install updates, and re-enable WLAN in BIOS. It will work.

  • 3
    I recommend expanding this with more explanation--both about what to do to access that setting, and why. Sep 13, 2014 at 3:59
  • 1
    Actually, it seems that kernel shipped with Ubuntu 14.04 image doesn't support the wireless chip on board of VivoPC VC60 and goes in kernel panic. But newer kernels do, so you just need to disable WLAN in BIOS at first, install Ubuntu and all the available updates, and then re-enable it in BIOS. With system updated it works flawlessly.
    – gerlos
    Sep 25, 2014 at 10:43
  • seems broken again in 15.10, would like to know what kernel version fixes the kernel panic
    – Mateo
    Nov 4, 2015 at 21:34

I just installed Ubuntu 14.04.1 on an Asus VivoPC VM60 by temporarily disabling the Wireless Network setting in the BIOS. This stops the Grub Loader from aborting during installation. After the installation is complete, go back into the BIOS and turn the Wireless Network setting back ON. The wireless adapter will automatically be recognized and installed during the next boot up.

To enter BIOS, press the F2 or Del keys during power up.

In the BIOS, choose the ADVANCED screen and select Onboard Devices Configuration. Then select WLAN Controller and change the setting from Enable to Disable. To save the changes and exit, press F10.


Installing Ubuntu 12.10 LTS worked! Not sure why 14.04 didn't work... The update manager popped up and asked me if I wanted to upgrade to 14.04; I decided to give it a try to see what happens. The upgrade is really slow (taking 1-2hours), but so far seems to be working... I'll check back in tomorrow after it finishes if it fails...

  • Forgot to mention that in order to install ubuntu on this machine, you have to enter the bios (by pressing f2 when you first turn the computer on) and change the OS-type to "Other OS" as opposed to "Windows" (which was pre-installed). Aug 12, 2014 at 3:56
  • Nope! Upgrading to 14.04 did not work! Everything seemed to work until I rebooted and then I ended up with the system hanging and the same panic message as before. So, as of 8-13-2014, my solution will be to reinstall 12.0.4 and not upgrade... Aug 14, 2014 at 0:20
  • Welcome to Ask Ubuntu, You can edit your answer and no need for comments.
    – user.dz
    Feb 3, 2016 at 23:45

I also tried to install Ubuntu on Asus VivoMini VM45, and unfortunately the update to the latest kernel version (now it is 4.15.0-36) does not solve the problem. As I understand, the problem is in the RTL8723BE wifi chip and its driver. A temporary solution,that I found is:

  1. Installing the OS with the Wifi controller disabled in BIOS.
  2. Config GRUB to running OS with the option pci=noaer
  3. Turn WIFI on.

More detail and how to set up a GRUB, on link:

This bug is described here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .