10

For some reason, sometimes when I log in the top panel applets appear garbled. For instance the session applet is missing its icon, and the current username is repeated twice. This doesn't happen very often, but when it does the session applet is not responsive so I can't get to the log out menu option.

Is there any other way to log off the current user other than using the (non working) session applet?

  • 1
    It might be worth trying to restart your gnome panel. Open a terminal (Ctrl+Alt+t, by default) and type killall gnome-panel, then hit enter. Then wait a few seconds and it should restart. If it doesn't, type gnome-panel, and hit enter again to start it manually. – Matt Jul 31 '10 at 21:12
10

Press Alt+F2, type gnome-session-save --logout, then hit enter. If an application is blocking logout, try gnome-session-save --force-logout

| improve this answer | |
4

If you enable Ctrl+Alt+Del, you can use that to kill the X server, which will log you out. To enable this, go to System -> Preferences -> Keyboard, then go to the Layouts tab and click Options. Expand the "Key sequence to kill X server" and check the box.

| improve this answer | |
  • 1
    That's a good tip, but if you do it that way your sesion won't be saved right? – Cesar Jul 28 '10 at 19:56
  • That is probably true. I don't use session saving so I didn't think about that. – Alex Grin Jul 28 '10 at 19:58
  • 1
    You can use RightAlt+SysRq+k to kill X without having to modify your configuration. On my keyboard the SysRq key is above print screen. Actually, you can do a lot with it: en.wikipedia.org/wiki/Magic_SysRq_key – Matt Jul 31 '10 at 21:13
  • Thanks for the info. I've started using Ubuntu after some time away and wasn't aware of the keybinding. – Matt Setter Nov 20 '13 at 7:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.