36

When a LUKS encrypted partition pops up the unlock window it gives 3 options for how to remember the password. The "Remember password until you logout" is always ticked by default. Is there a way to make "Forget password immediately" the default?

Enter a passphrase to unlock the volume:

[ ] Forget password immediately
[x] Remember password until you logout
[ ] Remember forever
  • 1
    Did you find an answer to your question? I would like to do the exact same thing, but I have only been able to find posts/questions explaining how to auto-mount encrypted disk, or something similar. – Justgivemeaname Mar 18 '15 at 20:57
  • 1
    related question here – Jose Raul Barreras Aug 17 '18 at 18:08
0

I believe the setting comes from your desktop environment, e.g. GNOME. Not related to LUKS or the encryption.

If GNOME is your desktop environment, you should change GNOME settings. One way is to install gconf-editor by

sudo apt install gconf-editor

You might be able to find the relevant default setting there.

| improve this answer | |
  • 5
    For modern versions of gnome (everything from the last decade) you should use dconf-editor instead. The key is org.gnome.shell.remember-mount-password. From the description: "The shell will request a password when an encrypted device or a remote filesystem is mounted. If the password can be saved for future use a “Remember Password” checkbox will be present. This key sets the default state of the checkbox." – felinira Jun 19 '19 at 18:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.