24

I need to compile HDF5 ,and after configure process ,i receive this error:

configure: error: C++ preprocessor "/lib/cpp" fails sanity check

And I know i have cpp installed on my ubuntu

Any help would be really appreciated :) This is the output of dpkg --list | grep compiler

ii  gcc                                                        4:4.8.2-1ubuntu6                                    amd64        GNU C compiler
ii  gcc-4.8                                               4.8.2-19ubuntu1                                     amd64        GNU C compiler
ii  gfortran                                              4:4.8.2-1ubuntu6                                    amd64        GNU Fortran 95 compiler
ii  gfortran-4.8                                          4.8.2-19ubuntu1                                     amd64        GNU Fortran compiler
ii  hardening-includes                                    2.5ubuntu2                                          all          Makefile for enabling compiler flags for security hardening
ii  libllvm3.4:amd64                                      1:3.4-1ubuntu3                                      amd64        Modular compiler and toolchain technologies, runtime library
ii  libxkbcommon0:amd64                                   0.4.1-0ubuntu1                                      amd64        library interface to the XKB compiler

And this is th error i recieve:

  nazanin@barashka:~/hdf5-1.8.13$ ./configure --with-zlib=/home/nazanin/local    --prefix=/home/nazanin/local
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking shell variables initial values... done
checking if basename works... yes
checking if xargs works... yes
checking for cached host... none
checking for config x86_64-unknown-linux-gnu... no
checking for config x86_64-unknown-linux-gnu... no
checking for config unknown-linux-gnu... no
checking for config unknown-linux-gnu... no
checking for config x86_64-linux-gnu... no
checking for config x86_64-linux-gnu... no
checking for config x86_64-unknown... no
checking for config linux-gnu... found
compiler 'gcc' is GNU gcc-4.8.2
checking for config ./config/site-specific/host-barashka... no
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking if unsupported combinations of configure options are allowed... no
checking if Fortran interface enabled... no
checking if Fortran 2003 interface enabled... yes
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking how to run the C++ preprocessor... /lib/cpp
configure: error: in `/home/nazanin/hdf5-1.8.13':
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details

Do i have to copy the config.log here?Thank you

  • Please show some lines above and below! – Volker Siegel Aug 11 '14 at 7:39
  • con you output the result of dpkg --list | grep compiler? – AlexGreg Aug 11 '14 at 7:47
29

If your configure output looks similar tho this, the C++ compiler is missing:

[ ... ]
*** C++ compiler and preprocessor
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking how to run the C++ preprocessor... /lib/cpp
configure: error: in `/home/ubuntu/.local/share/Trash/files/openmpi-1.4.1':
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.


To install the GNU C++ compiler, use
apt-get install g++


The configure output shows that ./configure tried to find a C++ compiler by checking for a lot of known compiler names, one by one.
At the start, we see that g++ is missing - the preferred one, checked first.
But it goes on trying to find some other compiler that you may prefer to use.

| improve this answer | |
22

I got similar type of error during installation of protobuf-2.5.0 on centos 7, for this i have to install gcc-c++ by command -

 yum install gcc-c++
| improve this answer | |
  • 2
    yum is the package manager of a different Linux distribution which is off topic here. Ubuntu uses Apt. – David Foerster Aug 2 '16 at 12:02
  • 11
    I am just going to make a shoutout that google brought me here and his answer was still helpful. – Shadoninja Oct 3 '16 at 17:21
  • 3
    Thank you for this answer, even if it's technically off-topic. Helped me out. – Ed Daniel Sep 23 '17 at 10:58
  • 2
    Thanks. This save me installing PHP 7.0 on a Amazon Linux Machine. – Marcos Regis Jan 23 '18 at 16:51
2

My solution was to make a symlink at /lib/cpp that points to gcc.

ln -sv "$(which gcc)" /lib/cpp

| improve this answer | |
1

putting this in your environment might do the trick:

GCC_PATH=#add the root directory to the gcc installation
export CPPFLAGS=-I$GCC_PATH/include/c++/5.3.0:$CPPFLAGS

If it works it means there is a library conflict between the version of gcc you wish to use and the version of gcc it is attempting to include.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.