I have bought a new laptop, Toshiba Satellite NB10t-A-101, with pre-installed Windows 8, after one day of figuring out how to install Ubuntu in UEFI I finally managed to do it (which wasn´t easy, as M$, Intel and Toshiba have made it more difficult with this model). It installed correctly. I created new partitions (making space beforehand in Windows 8). However after the installation the Windows boot manager turns on, with both Windows 8 and Ubuntu options. After selecting Ubuntu I am getting the same WUBI error as described here: Installing Ubuntu Alongside a Pre-Installed Windows with UEFI

 Windows failed to start. A recent hardware or software change might be the 
cause. To fix the problem:

  1. Insert your Windows Installation disc and restart your computer. 
  2. Choose your language settings, and then click "Next."
  3. Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer 
manufacturer for assistance.

    File: \ubuntu\winboot\wubildr.mbr
    Status: 0xc000007b
    Info: The application or operating system couldn't be loaded because a 
          required file is missing or contains error.

Which is already strange, as I thought the installation was in EFI mode (note- the secure boot option was disabled since the beginning, so this shouldn´´t be the cause). However after going to the "repair" options, the Windows menu appears (the same menu that allows to enter UEFI configuration), and in the "boot from device" option one additional figure appears- "ubuntu" which boots directly into the previously installed Ubuntu (14.04.1 LTS).

At this point I hoped the boot-repair would help. I followed the instructions from here: https://help.ubuntu.com/community/UEFI ("Converting Ubuntu into EFI mode"), unfortunately it does not help and I am getting this error:

 An error occurred during the repair.

Please write on a paper the following URL:

In case you still experience boot problem, indicate this URL to:

You can now reboot your computer.
 Please disable SecureBoot in the BIOS.

A broken Wubi has been detected. Please fix it this way:

After rebooting I am getting the same initial error (missing WUBI file) and can only enter Ubuntu as described above. Why is Ubuntu still looking for the WUBI? How can I repair the boot options, maintaining dual-boot with Windows? (unfortunately I still need Windows for one program that won´t emulate, also the shop salesman told me I would loose warranty if I delate Windows)

I´m a beginner user and getting to this point was very hard- please, use simple explanations :)

EDIT: Photograps of the boot process. After the error message I can go to the other windows menu and "boot from device"

enter image description here enter image description here

enter image description here

enter image description here

  • Could you please add screenshots/photos of the menu entry? You should be able to boot from the UEFI boot menu via entry Boot0006* ubuntu HD(2,200800,82000,2f11f25e-4303-11e3-be2a-0c54a5038f2e)File(EFIubuntushimx64.efi), If that works, you can arrange the boot order accordingly, or to what ever fits your needs.
    – LiveWireBT
    Aug 11 '14 at 11:11
  • I think that you did almost everything correct, but somewhere this entry got created and causes confusion or misconception. I don't have such entries when I do my UEFI installs, and everything works as I expect. May be boot-repair is causing this confusion and that there is something that should be fixed or improved. But I have no need for using boot-repair.
    – LiveWireBT
    Aug 11 '14 at 11:29
  • Ubuntu seems to be already the first entry (BootOrder: 0006,0000,2003,2001) and you should see GRUB instead of the Windows Bootloader, are you sure you followed the instructions (Please disable SecureBoot in the BIOS.) correctly?
    – LiveWireBT
    Aug 11 '14 at 11:59
  • Thank you LiveWireBT How do I use this entry you wrote? Paste it into terminal? I wil now try to post the phtos you asked for.
    – Malinowski
    Aug 11 '14 at 11:59
  • Yes, I am sure the secure boot is disabled. I checked.
    – Malinowski
    Aug 11 '14 at 12:00

I did a quick look in the manual for the laptop and F12 (confirmed to be working) should have been the right key according to instructions for booting from external media. You should probably check the manual yourself.

UEFI firmware update

There is the possibility that the UEFI firmware of the laptop does something else than what is expected according to the output from efibootmgr -v.

BootOrder: 0006,0000,2003,2001
Boot0006* ubuntu HD(2,200800,82000,2f11f25e-4303-11e3-be2a-0c54a5038f2e)File(EFIubuntushim‌​x64.efi

You should check if there is a firmware update available to update and check again after the update if it fixed your issue.

Per HDD-default UEFI bootloader

Another possbibility is that the default bootloader (\EFI\BOOT\BOOTx64.EFI on each HDDs ESP) is always booted (seems to be the case). Check if you can change this behaviour. A fully functional firmware should be able boot the ubuntu or Windows Boot Manager entries (as seen in the efibootmgr -v output) instead of the default one. I found a related post in a blog.

My general advice is too back up \EFI\BOOT\BOOTx64.EFI and replace it. I prefer gummiboot (tested, works), rEFInd is also possbile. I don't know what boot-repair does or suggest for this.

This really seems to be a firmware issue and installing another distribution does not seem to improve on this (I also found a forum post for Fedora with a similar issue).

Suggested solution

You con only boot the \EFI\BOOT\BOOTx64.EFI file on a harddrive with this laptop, so you need to replace it with something, that can boot more than just Windows. Running boot-repair will not help or make confusion worse.

  1. Get gummiboot

    Download gummiboot from the Arch Linux repositories. (Everything is fine, we are just doing Linus Torvalds style package management. You can find the download link on that page far on the right under Package Actions > Download From Mirror)

    Mount the EFI System Partition (ESP) and backup all existing files on the ESP (e.g. use zip or tar). You can put the backup file at the root of the partition, there should be enough space.

    Extract gummibootx64.efi from the package (it's under /usr/lib/gummiboot/) and copy it as \EFI\BOOT\BOOTx64.EFI to your ESP.

  2. Configure gummiboot to boot GRUB

    Create folders along the path loader/entries/ at the root of your ESP and create a file named ubuntu-grub.conf with the following content:

    title          Ubuntu GRUB
    efi            \EFI\ubuntu\grubx64.efi

    You also need to add the file loader.conf in loader/ to make gummiboot work.

    default        Ubuntu GRUB
    timeout        4

    default is the title of the default entry to boot. Edit appropriately if you have chosen another title.

  3. Reboot

    That's it. Gummiboot will automatically find and create menu entries to boot Windows.

  • Just to make sure- by updating the UEFI you mean to do it from Windows? I found this: microsoft.com/en-gb/download/details.aspx?id=38405 Also, the Wubi wiki (wiki.ubuntu.com/WubiGuide) says that Wubi does not work on Windows 8. Yet on powering he laptop, the windows bootloader is looking for Wubi. The boot-repais also claims that a broken Wubi has been found. How do I eliminate this broken Wubi? Maybe it is this Wubi that caused this problems (maybe it was installed by the Live Ubuntu USB at the beginning- the option "help me to boot from usb")?
    – Malinowski
    Aug 12 '14 at 18:04
  • I justr tried installing the rEFInd, you recommended, and another strange thing happened. When powering the laptop, the same Windows Boot Manager appears. However when restarting windows and entering into the "boot from device option" (as at the photograph above), beside the ubuntu option there is the rEFInd one. So I can boot into both rEFInd, and GRUB from there. It sees as if the Windows Boot Manager is somehow set to a superior position. Does it make the situation clearer? Any new ideas?
    – Malinowski
    Aug 12 '14 at 18:49
  • I technically can use both Windows and Ubuntu now, but to boot into ubuntu I need to firsly start windows, restart it while holding "shift" button, and than "boot from device" and choose Ubuntu (or now also rEFInd). I would be very happy if there would be some possibility of fixing it without loosing the windows (and thereby loosing warranty).
    – Malinowski
    Aug 12 '14 at 18:50
  • @Malinowski Thank you for your replies. I am trying to get my hands on a laptop of that model to recreate what you have, this may take a few days though.
    – LiveWireBT
    Aug 12 '14 at 18:58
  • Thank you so much! That would be great. I'll wait for your response.
    – Malinowski
    Aug 12 '14 at 19:44

WUBI is incompatible with an EFI-mode boot, which is almost certainly what your computer uses if it came with Windows 8 or 8.1 pre-installed. I recommend you delete your WUBI installation and perform a standard EFI-mode installation. (See also the Ubuntu community wiki and my page on EFI-mode installations for more information.)

  • Thank you @Rod Smith! I have uninstantiated the Wubi files (from Windows partition), and the laptop boots now directly into Windows. I can still open Ubuntu when restarting and opening it as a "device" (as on the photographs above). I did boot-repair again (which detects the EFI and should re-install GRUB in EFI mode) but it doesn't work. I did my initial Ubuntu install as described in the link you provided. Do you think a re-install will change anything?
    – Malinowski
    Aug 16 '14 at 12:38
  • BTW. the WUBI was installed from the live usb. Maybe this is a bug to be repaired? Initially my windows didn't allowed me to boot anything from USB, and only after I run the "help me boot from usb" option from my live usb in Windows it allowed me to do it. This is probably when the WUBI was installed. Shouldn't the live usb detect which windows I am running and avoid installung WUBI (although it did help to boot from the USB, as without it I couldn't even start the installation process).
    – Malinowski
    Aug 16 '14 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.