When I want to clear cache using javaws - viewer these error comes. I am trying to launch my topcoder arena.

Picked up JAVA_TOOL_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar 
Exception in thread "main" java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at sun.instrument.InstrumentationImpl.loadClassAndStartAgent(InstrumentationImpl.java:382)
    at sun.instrument.InstrumentationImpl.loadClassAndCallPremain(InstrumentationImpl.java:397)
Caused by: java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "getenv.JAYATANA_LIBAGPATH")
    at java.security.AccessControlContext.checkPermission(AccessControlContext.java:372)
    at java.security.AccessController.checkPermission(AccessController.java:559)
    at java.lang.SecurityManager.checkPermission(SecurityManager.java:549)
    at java.lang.System.getenv(System.java:885)
    at com.jarego.jayatana.Agent.premain(Unknown Source)
    ... 6 more
FATAL ERROR in native method: processing of -javaagent failed
Aborted (core dumped)

My arena doesn't launch. when I try to open ContestAppletProd.jnlp icedtea starts and in 2 seconds its goes away, I mean it gets stopped and it doesnt launch my arena.

I tried to clear the cache using

javaws -viewer and also with javaws -XclearCache or rm -rf ~/.icedteaCache/cache .

but nothing worked.

What should I do now to launch my arena?

N.B: I reinstalled icedtea-plugin, openjdk-7-jre and jdk, but nothing worked.


You must log in to answer this question.

Browse other questions tagged .