4

I installed Ubuntu 14.04 on my computer and worked OK for about 2 months but now when I try booting it I only get this:

wn-block(0,0)
[     0.747081] CPU: 1 PID: 1 Comm: swapper/0 Not Tainted 3.13.0-33-generic #58-Ubuntu
[     0.747132] Hardware name: Dell Inc. Inspiron N5010/0TD2K6, BIOS A08 09/13/2010
[     0.747183] 0000000000008000 ffff880131e3dd70 ffffffff8171bd04 ffffffff81a3c210
[     0.747373] ffff880131e3de68 ffffffff81714f05 ffffffff00000010 ffff880131e3de78
[     0.747566] ffff880131e3de18 ffffffff81715a26 ffff880131e3de88 00000000000000cc
[     0.747761] Call Trace:
[     0.747810] [<ffffffff8171bd04>] dump_stack+0x45/0x56
[     0.747861] [<ffffffff81714f05>] panic+0xc8/0x1d7
[     0.747908] [<ffffffff81715a26>] ? printk+0x067/0x69
[     0.747959] [<ffffffff81d3646a>] mount_block_root+0x225/0x2b0
[     0.748008] [<ffffffff81d36692>] mount_root+0x53/0x56
[     0.748056] [<ffffffff81d36801>] prepare_namespace+0x16c/0x1a4
[     0.748105] [<ffffffff81d3616e>] kernel_init_freeable+0x1f3/0x200
[     0.748155] [<ffffffff81d358e5>] ? do_early_param+0x88//0x88
[     0.748205] [<ffffffff8170a1e0>] ? rest_init+0x80/0x80
[     0.748252] [<ffffffff8170a1ee>] kernel_init+0xe/0x130
[     0.748303] [<ffffffff8172c63c>] ret_from_fork+0x7c/0xb0
[     0.748351] [<ffffffff8170a1e0>] ? rest_init+0x80/0x80

Can anyone tell me what to do and if that is a virus?

3
11

Do you see the boot menu?

-- Boot menu, 14.04 LTS --
Ubuntu
Advanced options for Ubuntu
System Setup

... if not, try hitting ESC while the computer starts up... before and/or while "Ubuntu ....." is shown (if it is shown).

When or if you see the menu: Use the cursor keys ( and ) to select Advanced options for Ubuntu and press enter

By that you should get a menu similar to this:

-- Advanced options for Ubuntu --
Ubuntu, with Linux 3.15...-generic
Ubuntu, with Linux 3.15...-generic (recovery mode)
Ubuntu, with Linux 3.13.0-24-generic
Ubuntu, with Linux 3.13.0-24-generic (recovery mode)

You will probably have a different set of entries, the recovery mode items are for more advanced fault finding and remedy. Keep out of those for the time being.

Instead use the cursor keys and select what you have in the place where it reads Ubuntu, with Linux 3.13.0-24-generic above. Then press enter again...

I hope that will allow your computer to be used...

Please tell us if this helped, we might be able to help you get beck to normal depending on any more detail you provide on the outcome of it.

Edit your posting and add a line with <hr> and insert more details after it.
Repeat the same if you have more...


-- Addition, for fixing or removing the problem with the default boot option --

The problem seems to be a nonworking setup for the latest(?) linux-kernel - this has probably been added together with updates - and failed to install properly.

To try to get it up and running, boot using the method above, login and then do:
Hold CTRL+Alt and hit T - this should open a "Terminal" (check menu:Help>About with the window active, it says Gnome Terminal with the default setup).

If you're unfamiliar with the Terminal: In that window you should now see the last line displaying a single $, if you type anything on the keyboard, your typing will appear to the right of it. The first word will be taken as a command to execute, the remainder of the line will be passed to that command as "arguments" allowing the command to interpret them and act accordingly.

Now, a first simple attempt to FIX the problem: Type what is in left side column in the list below; the text after and including the # is the technical explanation of what that should do. This is an attempt to rebuild the boot menus. This MAY be enough, but may also fail.

Press enter on each line. As you do so on the FIRST line, you will be asked to type your password, if you fail to get it right you will be asked two more times. If you fail in the third attempt, just press (cursor up) once and then enter again.

sudo update-initramfs -u                          # remakes boot ramdisk
sudo update-grub2                                 # re-creates boot menu

As you have done that - assuming nothing reads "error" or "fail" in the output - you may try to reboot - using the default option this time.
If that works - then all should be fine... no need to do more. :-)

If it DOESN'T work, then the "easy" fix is to remove the non-working option. This is also something you do from the Terminal (there might be other ways too, but I'll ignore them ;-) - and you need to boot the same way as before.

This prints the currently ACTIVE kernel name - the one you're using.

uname -r          

Again: which kernel you're USING, especially take note of the EXACTLY how the numbers read zeros and all - do not "abbreviate" in any way.

Now, with that known: ... you will see similar series of numbers on each line from what is listed by this set of commands - one of the number-sets should match exactly:

dpkg --list | head -n 5 && dpkg --list | grep linux-image

the first 5 lines is a summary of information that may help - if you have to copy it here - in case of trouble. These five lines explains the first two/three characters on the following lines. You may need to expand the width of the Terminal window to see "lines" as they are quite long and tend to wrap down on one extra line with the standard width.

Now the 'linux-image-x.x.x.x-generic' that does match what uname -r above printed is the one to keep.
But ALL the others - I suggest to FIRST take the one listed on top in the 'Advanced options' menu - may be removed with

sudo apt-get purge linux-image-x.x.x.x-generic

... where you are to replace 'linux-image-x.x.x.x-generic' with the exact same as dpkg --list ... (above) said in column two.

Generally there is no need to keep more than the latest working option / kernel in the boot menus. If there are too many it may actually create a problem: the related part of the hard disk growing full.

IMPORTANT: As you have done all (or just one), repeat the same as above once again.
This should hopefully, now tell NO errors or fails.

sudo update-initramfs -u                          # remakes boot ramdisk
sudo update-grub2                                 # re-creates boot menu

update 2015-05-17
How to use kernel 3.16 on 14.04 LTS
Follow the instructions for Trusty here:
https://wiki.ubuntu.com/Kernel/LTSEnablementStack
NOTE: Avoid kernels later than 3.16 for the time being, unless you're knowledgeable.

7
  • thank you very much ill try it now and inform you if it works! – Marina Oikonomou Aug 10 '14 at 23:36
  • it worked (the second time i tried)! Thank you a lot! (so if it happens again I repeat this process) But... Ubuntu didn't boot from -- Boot menu, 14.04 LTS -- but only from Ubuntu, with Linux 3.13.0-24-generic – Marina Oikonomou Aug 10 '14 at 23:45
  • > it worked - ok :-) -- now you will probably have to do it this way (every time you boot) until you have 'cleaned out' what is faulty with the default option (usually equal to the first line in the -- Advanced options... -- menu). Now, I'll try to explain what to do - adding it above. – Hannu Aug 11 '14 at 7:07
  • Now, I have added quite a bit of text - much what I explain is also available here - but with different approaches - but also note the recommendation present there - to keep at least one extra boot option (kernel version). – Hannu Aug 11 '14 at 9:38
  • ok i am trying it but it says: marina@marina-Inspiron-N5010:~$ sudo apt-get purge linux-image-3.13.0-33.58-generic E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. did i interrupt something??? – Marina Oikonomou Sep 2 '14 at 1:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.