6

I have this WiFI dongle (Edimax EW-7811Un)

Is there an Ubuntu package I can use to get it working? If not, how can I get this WiFi to work?

4

This worked on Ubuntu 14.04 LTS and 14.10 (tested and works)

sudo apt-get update && sudo apt-get install git build-essential linux-headers-generic dkms

git clone https://github.com/dz0ny/rt8192cu.git --depth 1

Currently, as of 22/04/15, there is a bug when installing this with GCC 4.9 or newer. To fix this bug remove line 1580 from rt8192cu/os_dep/linux/usb_intf.c This line should read:

DBG_871X("build time: %s %s\n", __DATE__, __TIME__);

Lastly run

cd rt8192cu

sudo make dkms

Reboot and you are done.

Source

|improve this answer|||||
2

For later kernels ( 3.9 + ) this article on the Edimax site was very helpful... Paraphrased below

If you have issue(s) with the built-in driver, you can try this open source driver from github.

Plug in the EW-7811Un to your system's USB port (2.0 preferred), making sure your system has temporary Internet connection

Open a Terminal program and make sure your system is up-to-date

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade 

Note: You may need to restart your system if a kernel update has been installed.

Install the necessary packages to compile a device driver:

sudo apt-get install linux-headers-generic build-essential dkms git

Reboot, then clone the github repository:

git clone https://github.com/pvaret/rtl8192cu-fixes.git

Note: Right after "rt", it is a letter "l" (like Larry), not a number "1" (like 1980.)

Set up as DKMS module:

sudo dkms add ./rtl8192cu-fixes 

Build and install the rtl8192cu driver:

sudo dkms install 8192cu/1.10 

Refresh modules list:

sudo depmod -a 

Blacklist the native kernel driver:

sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/ 

Disable power management:

sudo cp ./rtl8192cu-fixes/8192cu-disable-power-management.conf /etc/modprobe.d/ 

Restart your system to use the new driver.

That's it!

For removal, you can use the following commands.

sudo rm /etc/modprobe.d/blacklist-native-rtl8192.conf
sudo rm /etc/modprobe.d/8192cu-disable-power-management.conf
sudo dkms remove 8192cu/1.10 --all
|improve this answer|||||
1

Sure, on the page you gave there is a download link. Click that and it takes you to a list of drivers (scroll down a bit).

To make it easier, here is the direct download.

Extract them, then do

cd /path/to/extracted/files

then

chmod +x install.sh

and finally

./install.sh
|improve this answer|||||
  • Those look like something that needs to be compiled. I did try that, but the compile fails with errors. – Zeno Aug 10 '14 at 19:47
  • You ran the script? – Tim Aug 10 '14 at 19:48
  • 1
    @Zeno - if it does fail with a error, what error? – Wilf Aug 10 '14 at 19:49
0

With an ethernet connection do:

sudo apt-get install --reinstall linux-headers-$(uname -r) linux-headers-generic build-essential git dkms
git clone https://github.com/pvaret/rtl8192cu-fixes.git
sudo dkms add ./rtl8192cu-fixes
sudo dkms install 8192cu/1.9
echo "blacklist rtl8192cu" | sudo tee -a /etc/modprobe.d/blacklist.conf

Reboot

|improve this answer|||||
0

Hello, since this is the first google result, answering here! thanks to this source!

*also heads up latest ubuntu version recognizes this device without any setup!

  1. Download the driver from edimax(choose linux version)
  2. Put this onto your linux device
  3. You will need to get to the driver files. Keep extracting until you see a file called "makefile"**

I found it here:

EW-7811Un_Linux_driver_v1.0.0.5>EW-7811Un_USB_linux_v4.0.2_9000.20130911>driver>rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911.tar>here you will find makefile!

now get the location of this folder, and go to it on terminal! (for example

cd Desktop/name/name/name/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911

just to check type in " ls " (without quotes) to find that makefile is there

4. Now type these commands in your terminal

make clean

make

(should take a while here just wait until its done) then type

sudo insmod 8192cu.ko

and it should work!

To not have to do this everytime you start comp, put this in terminal aswell

sudo cp 8192cu.ko /lib/modules/uname -r/kernel/drivers/net/wireless

sudo insmod 8192cu.ko

sudo depmod -a

|improve this answer|||||
  • 2
    Gotta love Ubuntu on RPi2 not having even a sodding make...Jesus Christ... – rbaleksandar Aug 21 '15 at 23:14
0

I think it is supported by default now.

http://www.daveconroy.com/turn-your-raspberry-pi-into-a-wifi-hotspot-with-edimax-nano-usb-ew-7811un-rtl8188cus-chipset/

|improve this answer|||||
0

I bit the bullet and bought one from thinkpenguin.com which are built for Linux and all major and not so major distros. It's plug and play without any fuss. We ended up needing a wireless extender as well owing to the massive outer walls in a 150 year old house. It was not too bad without it, but if you know where to look a good one can be had for under $30 and works like a charm. Signal strength is just a tad lower than being right beside the (fibre) modem.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.