2

I started up my ubuntu and it lead to a login prompt. I input the correct password for the account. It went to a black screen for a flash, but it made the default "bongo" error sound and aborted back to the same prompt. No error was displayed.

I know this is the right password, because inputting any other password will make the prompt say "Invalid Login". Only the correct password causes the error.

Also, on that note, my account is set to automatic login.

What can be done to fix this?

  • Can you login to the terminal? Press Ctrl-Alt-F2 to get to one, and try. – muru Aug 10 '14 at 18:05
  • @Tim, sometimes F1 has log messages hiding the prompt (or causing it to not show up). – muru Aug 10 '14 at 18:23
  • I was able to login using control-alt-f2 and using that prompt. I simply added a new user with new privileges as a cheap way around the problem. It seemed to say there was a KeyError in the cache or something – corvid Aug 10 '14 at 18:45
0

From the info that you have provided it seems to me that there might be an issue with the display manager, it seems the display manager could not start your session or load the desktop environment.

There might also be an issue with the permission of the /tmp folder (happened in my case).

| improve this answer | |
  • I have the same problem. I login in F1 or F2 to reinstasll xorg, but same problem. What is Muru's suggestion you mentioned? – hakunami Mar 26 '15 at 1:21
  • @hakunami: The suggestion was "Can you login to the terminal? Press Ctrl-Alt-F2 to get to one, and try." ..note that you should ask a new question so that others can also help you.. – heemayl Mar 26 '15 at 14:33
0

I had done chmod 555 to my /home folder which created the problem. The solution is to change the permissions back by using someone else's laptop.

  1. do ssh (your laptop username)@(your IP)
  2. enter password(here u will be able to log in because you are accessing via terminal)
  3. cd ..
  4. chmod 755 (your username on laptop)

It solved the problem for me.

| improve this answer | |
  • SSH is not default-installed on laptops; the OP makes no indication that they have SSH, therefore this answer may not help future readers. – Thomas Ward Oct 21 '16 at 11:39
  • Press Ctrl-ALT-F1 for a local terminal, there is no need to do this remote – s1mmel Jul 5 '17 at 8:31
0

I have solved this problem by deleting the file.I created using the same method above, just substitute the filename. I created a .sh file in /etc/profile.d and then reboot, the problem comes here.

| improve this answer | |
0
  1. CTRL + ALT + F2

  2. sudo rm /home/(username)/.Xauth*

  3. restart lightdm

  4. back to normal.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.