wubi.exe used to work fine with earlier versions of ubuntu, but there is some issue with wubi for 14.04. I used to install ubuntu along with Windows as an add/removable program. when both files (wubi.exe and iso) placed in the same folder and wubi was run, the whole process didn't take more than 1-5 minutes to complete.

But this is changed in ubuntu 14.04, I did the same process. 1-downloaded iso file. 2-extracted wubi.exe from iso. 3-placed that wubi and iso in the same folder. 4-run the wubi.exe.

this is the same process that worked for earlier versions, even in 13.10; but in 14.04, wubi totally ignores the iso image and starts to download it again. It means I have to wait for almost 1 gigabytes to download every time when I try to install ubuntu 14 along with windows.

I searched a lot but can't find the satisfactory answer. there are opinions but it seems those answers and help is not based on experience but opinions only. So please answer it after trying it out yourselves. Thanks.

  • 1
    Possible duplicate of askubuntu.com/questions/159524/…. Let me know if that doesn't help/you've already tried that. – TheSchwa Aug 10 '14 at 8:05
  • Start by reviewing the log file in the %TEMP% directory. Or pastebin it if you need help. If you are using 14.04.1 it won't work because they didn't release a Wubi.exe for 14.04.1 (so it will always download the 14.04 image). – bcbc Aug 11 '14 at 17:11

I got this problem solved after a few experiments. Disconnect your internet and then start wubi.exe and it will use the iso file in the same directory.

It may be a good idea to reconnect internet when your computer restarts for proper installation of ubuntu.

Thanks everybody.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.