0

This question already has an answer here:

I recently used Gparted to resize my partition, so I have 200GB of unallocated space that I want to install Windows 7 to.

The problem is, my computer won't let me boot from USB. It let me boot Ubuntu from a USB, but not Windows.

I'd been having serious issues even creating a bootable Ubuntu USB. Startup Disk Creator, UnetBootin (and UnetBootin 494), WinUSB, etc all didn't work. I kept getting a black screen after the grub, and then returned to the grub.

Finally, p7zip via the Terminal did the trick, and let me boot into Try Ubuntu, so I could use Gparted to partition the HDD. Now that I have unallocated space, I want to install Windows 7.

I followed the instructions to put my Windows ISO on a USB via UnetBootin, but my computer doesn't detect the USB afterwards. The instructions say to format the USB as NTFS, and I did. It detects FAT32, but won't boot from it.

I tried WinUSB, but received an error message at the end of it that stated the USB wasn't an EFI device.

I've turned off Secure Boot, Fast Boot, and set the USB to boot priority.

Can I use p7zip again? I tried mounting the ISO, clicking and dragging the files onto the USB, and booting that way (which several instructions had said worked), but nothing happens.

I'm running out of tools and USBs. I've used 3 already, including a brand new one. Still nothing. I could use some advice!

EDIT: I tried WinUSB again with a fresh USB. Here's the error output:

Installation failed !
Exit code: 512
Log:
Formating device...
Mounting...
mount: block device /home/zachary/Windows7Ultimate/Windows7Ultimate.iso is write-    protected, mounting read-only
Copying...
Installing grub...
Installing for x86_64-efi platform.
grub-install: error: /media/winusb_target_1407629458_2779 doesn't look like an EFI  partition.
.
Error occured !
Syncing...
/usr/bin/winusb: line 78:  7228 Terminated              while true; do
sleep 0.05; echo 'pulse';
done
Cleaning...
/usr/bin/winusb: line 78:  7371 Terminated              while true; do
sleep 0.05; echo 'pulse';
done
Umounting and removing '/media/winusb_iso_1407629458_2779'...
Umounting and removing '/media/winusb_target_1407629458_2779'...

EDIT 2: When I use UnetBootin, the download completes and asks me to reboot. When I reboot and go into BIOS, the USB doesn't show as a bootable option. It's just not there. It should be noted that my computer came with Windows 8 pre-installed. Would that make a difference? I also can't change UEFI to Legacy from BIOS.

marked as duplicate by Eliah Kagan, Florian Diesch, Lucio, Tim, Eric Carvalho Aug 11 '14 at 11:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This probably is a laptop that came with Windows 8. Did you enable Launch CSM and Launch PXE OpROM ? And, if you have the option in the BIOS, change booting mode from UEFI to Legacy. – Templer Aug 10 '14 at 0:56
  • Nope, I tried all those solutions already. – Hearthing Aug 10 '14 at 1:30
  • I recommend expanding this question with details about everything you've tried and exactly what happened, including all commands you ran and any error messages, even for the non-WinUSB methods. (For example, what happened when you tried this way?) – Eliah Kagan Aug 10 '14 at 1:32
  • I have had problems booting from USB in laptops with Win8, it's weird because it does not detect any USB device, I remember that disabling enabling the Secure boot, after rebooting the USB it's detected, this may not work in all laptops but you can try – tttony Aug 10 '14 at 3:55
  • @tttony I edited my answer to answer your comment. I've tried disabling Secure Boot and Fast Boot, but it doesn't have any effect. If there's some way I can change UEFI to Legacy, that'd be great. – Hearthing Aug 10 '14 at 4:14
0

I'm assuming you already checked the BIOS settings for boot order etc. since you mention Ubuntu does boot from USB. Also, make sure secure boot is disabled in the BIOS. In some instances, you have to set a BIOS admin/supervisor password before you are allowed to change the setting.

Other Possible issues could be the thumb drive, the utility you are using to create the windows USB install or the ISO. Are you sure the windows ISO is at all bootable ?

For best results, I'd recommend trying the Windows USB download tool

If you're sure the ISO is working and feeling a little bit bold, try Yumi. This (free for personal use) utility allows you to place multiple installations on a single thumb drive. With it, you can create a thumb drive which lets you choose between a mix of several windows versions and linux versions for installation.

  • Yes, I set it to boot priority, turned off Secure Boot, and turned off Fast Boot. Booting from the USB just takes me to the Ubuntu grub, where I can load into Ubuntu. See the above edit I made as to my WinUSB output. It says the ISO is write-protected. – Hearthing Aug 10 '14 at 0:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.