I installed 4.3 Skype. When I try to log in, it logs me in, I see a the box appear. Then it suddenly switches off. It quits.

  • Is this in wine? Or installed directly on ubuntu?
    – Tim
    Aug 9, 2014 at 18:59
  • directly, through apt-get install skype command Aug 9, 2014 at 19:04
  • Do you see an error message if you run it from terminal?
    – Tim
    Aug 9, 2014 at 19:06
  • @Tim sorry, but I was unable to open it from terminal. i could not find the folder it is located in Aug 9, 2014 at 19:14
  • just run skype in terminal...
    – Tim
    Aug 9, 2014 at 19:33

2 Answers 2


If you updated from Skype 4.2, this is because the database format has slightly changed. More precisely, the problem is that the format of how file transfer logs are stored differs slightly, and Skype 4.3 crashes right away because it cannot deal with the old format.

One possibility, as suggested in the other answer, is to completely remove your Skype directory (i.e., rm -r ~/.Skype). However, this also means that you will lose all your conversation history!

A much better solution is to fix the database yourself. Make sure Skype is not running, and proceed as follows:

  1. Install sqlite3:

    sudo apt-get install sqlite3
  2. Next, issue the following command:

    sqlite3 ~/.Skype/SKYPE_USERNAME/main.db

    ...where you have to replace SKYPE_USERNAME with your Skype username. This gets you inside Skype's SQLite database. There, issue the following command:

    UPDATE messages
      SET body_xml =(
        SELECT SUBSTR( body_xml, files_start, alt_end - files_start ) ||
               SUBSTR( body_xml, 0, files_start ) ||
               SUBSTR( body_xml, alt_end )
        FROM (
          SELECT msg.body_xml,
                 instr( msg.body_xml, '<files' )  files_start,
                 instr( msg.body_xml, 'alt="' ) + 5 alt_end
          FROM messages msg
          WHERE msg.id = messages.id
    WHERE type = 68
    AND body_xml NOT LIKE '<file%';

    And quit:


And voilà! Next time you start Skype and log in, it should work fine, and you'll still have all your conversation history.

Source: http://community.skype.com/t5/Linux/Skype-4-3-crash-on-ubuntu-14-04/m-p/3349043/highlight/true#M9417

  • Are you one of the skype developers :) I would never have thought of that myself. Thank you :) Aug 11, 2014 at 4:42
  • You're welcome. I'm not a Skype dev, but I experienced exactly the same problem. My first try was to remove (rename, actually) the ~/.Skype folder as some others here suggested. That worked, but I was loath to lose all my conversation history. So I googled and read through tons of forum posts, until I found the one that I linked to in my post. It's over at the Skype forums, and some people there are real Skype-gurus ;) Aug 11, 2014 at 8:49
  • Doesn't work. Amazed to access the database though. Mar 21, 2017 at 10:47
  • @AhsanulHaque This was ages ago... :) It worked for me back then, and it worked for other people on the Skype forums, as well as the OP here. Can't say why it doesn't work for you. Are you indeed upgrading from Skype 4.2 to 4.3? If you already have Skype 4.3 (which itself dates back to 2014...) and you are experiencing crashes, this may be due to totally other reasons. Mar 21, 2017 at 13:05

I had that problem - I found a post somewhere here about needing to delete the .Skype directory and now Skype 4.3 works. If you can find that post you will have your answer.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .