Let me start off by saying I'm dual booting 11.04 and Windows 7 on a Thinkpad T61p.

The problem may have arisen when I hit the power button during normal startup. I'm fully aware how stupid this is. I don't know why I did it. I did it.

Now, I can't get in to Ubuntu. Windows works fine. But when I try to start Ubuntu normally, it seems to run some checks, and does not start up. Sometimes, I see a black screen, and it tells me that it's running certain checks, and then, [ok]. Like... Battery Check Somethingorother [ok]

It'll give me 1-5 of these. And then it just does nothing, and I have to turn it off.

When I try to start in safe mode... I tried low graphics mode, and after going through a couple of dialogue boxes, I'm brought right back to the safe mode dialogue box. And if I hit 'resume,' a shell pushes up (still that grey on black "your computer is broken" type shell) and asks me to log in. I do, and try to run unity. It tells me something along the lines of: WARNING no DISPLAY variable set and then sets it to " :0" , which doesn't work.

And then I can't do anything, really, and I have to restart. (I don't know how to do this from the command line, so I just hard reset. That command would be helpful).

Does anybody have any idea how I can get Ubuntu working right again? FTP is less pleasant in Explorer than it is in Nautilus or w/e it is now.

| improve this question | | | | |
  • How did you install Ubuntu ? Wubi ? From a CD ? Just to be sure. sudo reboot will reboot for you :). – wojox Jun 28 '11 at 5:24
  • USB... I think I used that thing that sets up the USB for you. – Daniel Jun 28 '11 at 14:17
  • Another question mentioned a similar problem that had something to do with nvidia drivers. I know I have an nvidia card. Could that have something to do with it? – Daniel Jun 28 '11 at 15:07
  • I also replaced Unity with Gnome 3 at some point, and then went back to using Unity. The whole Gnome 3 install process was pretty shady, and then Gnome 3 itself was pretty shady... – Daniel Jul 3 '11 at 14:04

before formatting your HD or performing irreversible actions, consider using a livecd. your computer isn't 'broken'. you may want to check if your partition table is ok and your data is still there. if so, you may simply have to check your fs, which could be damaged. a file system check may be able to correct the errors. still, i can't understand why you managed to break your system. in order to check the status of your HD (it may be physically damaged) you may want to have a look at the smartmontools package which contains a tool to examine the conditions of your HD. I don't think re-installing any package will solve your problem but the configuration files of some packeges may be corrupted. then, remember that a re-installation (with --purge, maybe, but use it at your own risk) will overwrite the old conf files and create new ones. and remember that if acpid is installed and properly configured, a single, little push on the power button will cause your computer to shut down genlty, with no consequences.

and, this is a good chance to learn some odd command line stuff! :)

| improve this answer | | | | |
  • Can you give me a similar tool I can use from windows? I suppose I could remember "smartmontools," but the idea of restarting eight more times just to check this out seems underwhelming -- particularly if this check takes long, in which case, if I ran it from windows, I could watch Hulu while the check ran. – Daniel Jun 28 '11 at 14:19
  • there's also a package available for windows (if you really have to :D): take a look here sourceforge.net/apps/trac/smartmontools/wiki/Download – MarcDuQuesne Jun 28 '11 at 21:38
  • Uh... How in the world does smartmontools work? I can tell that it's a command line tool, but... what command should I use? I... I just don't know where to start with this thing. – Daniel Jul 3 '11 at 14:03
  • Well, I'm giving up on figuring out smartmontools. I suppose reinstalling is going to turn out to be the right answer. I'll start a new thread to figure out just how I should do that. – Daniel Jul 18 '11 at 21:31

First instead of pushing the Power Button try this command sudo reboot . As for the issues your having with unity not loading in safe mode or normal try to boot . Type sudo apt-get remove unity which should remove unity . Then type sudo apt-get install unity to reinstall you may get lucky . Chances are your going need to reformat ubuntu with your cd.

| improve this answer | | | | |
  • I think unity is installed fine -- it just tells me that there's something wrong with the whole display thing. I doubt I need to reformat, considering the filesystem seems to all be there when I mess with it via the command line. Also, I don't have a cd, I have a flash drive. What is this, 2005? – Daniel Jun 28 '11 at 14:15
  • You can also try to boot to the recovery console and try to repair <code>xserver</code> but i seriously doubt it will help the issue at hand. As far as running windows utillities its not a good ideal ubuntu file system is alot different . but if you want to watch hulu while you are in the live cd you can install gnash <code> sudo apt-get install gnash </code> it'll allow you to play hulu and youtube and other flash streaming sites – freebird Jun 28 '11 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.