I created a new user account without a password.

I later used the GUI and Terminal methods to add a password to this new account. I have tried several time with reboots, logout/login after adding the new password both from the root/administrator account and even this new user account.

The user still does not need to enter a password at the login screen.

Any next steps / ideas ?


  • Can you include the output of the terminal command getent group nopasswdlogin please? – steeldriver Aug 9 '14 at 2:05
  • nopasswdlogin:x:119:username – WRAP2 Aug 9 '14 at 2:25

It looks like username belongs to the nopasswdlogin group, which means that only the name is required to log in, regardless of whether a password is actually set for the account (note: this is not the same as autologin - which bypasses the login screen altogether).

You should be able to just remove the user from the group e.g. with terminal command

sudo gpasswd --delete username nopasswdlogin
| improve this answer | |

When logged in as the user, go to

System Settings > User Accounts > My Account

and make sure "Automatic Login" is set to "OFF".

| improve this answer | |
  • Automatic Login is set to OFF – WRAP2 Aug 9 '14 at 2:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.