2

I think my question is related to this post but I don't have ccsm installed at the moment, and I don't want to unless I have to (some of the things you can change in there can cause quite a lot of mess).

I am using Unity Tweak Tool, in particular to customize the behaviour of window snapping (top:maximize, left:left-half, right:right-half). However, when I activate this specific option, it seems to override my keyboard shortcuts CtrlSuper+///, which I normally use to move my windows across desktops.

I don't understand why Unity Tweak Tools would activate keyboard shortcuts for a feature that involves dragging the window around, and most importantly why these shortcuts would override mine. What is the easiest way to disable keyboard shortcuts for window snapping while preserving the feature using mouse-drag?

  • 1
    Unfortunately, compiz... I know that isn't the answer you want btut it is the answer... – Tim Aug 8 '14 at 19:38
  • Installing it won't break anything - just be careful what you edit. You can always reset compiz/ – Tim Aug 8 '14 at 19:44
1

So apparently installing CCSM is inevitable. As @Tim said just be careful what you edit.

sudo apt-get install compizconfig-settings-manager

Then open Unity Tweak Tool and activate window snapping:

Unity Tweak Tool

Then open CCSM and disable keyboard bindings in Window ManagementGrid

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.