0

My Ubuntu version 14.04 suddenly stopped discovering my comcast wireless router. I can see other routers. I can also connect to it by "Connect to a Hidden WIFI Network..".

Is this a router configuration issue?

Below is the ubuntu release and wireless hardware information.

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.1 LTS"

add wireless hardware
##### lspci #####

06:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
Subsystem: Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller [103c:1363]
Kernel driver in use: b43-pci-bridge
  • further steps.. ran "sudo apt-get update" and "sudo apt-get install linux-firmware-nonfree". no change – user313783 Aug 8 '14 at 19:37
  • Well, you said it yourself that you can connect to a hidden network, right? So it's definitely the router settings – Sergiy Kolodyazhnyy Aug 8 '14 at 20:03
  • Thanks for the reply. I checked the router configuration and the "Broadcast Network Name (SSID)" is enabled and I can see the router on many other devices (phones, WII, in fact another ubuntu machine with the exact same version of the os but different wireless card (Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)). I think something is broke in the driver. – user313783 Aug 8 '14 at 20:45
  • I should have also noted I'm still using the b43-pci-bridge kernel driver. I'm not sure how to replace it with the linux-firmware-nonfree install. – user313783 Aug 8 '14 at 20:48
1

I would try the tutorial here:

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx#b43%20-%20Internet%20access

Follow the instructions for your 4311. I have the 4318 and that page got mine working just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.