0

I have the same problem that the user in "Dummy Output in Ubuntu 14.04".

The difference is that cat /proc/asound/card0/codec* | grep Codec outputs:

cat: /proc/asound/card0/codec*: No existe el archivo o el directorio 

(It's in Spanish, it means it cannot find the file or directory)

More info:

$ sudo modprobe snd-hda-intel  
modprobe: FATAL: Module snd-hda-intel not found.

$ sudo alsa force-reload
Unloading ALSA sound driver modules: (none loaded).
Loading ALSA sound driver modules: (none to reload).

$ sudo aplay -l
aplay: device_list:268: no soundcards found... 

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family 
    High Definition Audio Controller (rev 04)

$ lspci -v | grep audio
(nothing)

$ locate snd-hda-intel
(nothing)

$ lsmod | grep snd
(nothing)
  • Can you add the output of sudo lspci -nnk | grep -A5 Audio – Braiam Sep 14 '14 at 13:20
2

First, we need to know what type of audio hardware (if any) the system detects:

lspci -v | grep audio

And

:~$ lsmod | grep snd

Please run this command and post the output. Should be something like the following:

:~$ lspci -v | grep audio
00:1f.4 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 \
  Audio     Controller (rev 02)
:~$

And

snd_intel8x0           38153  0
snd_ac97_codec        130285  1 snd_intel8x0
ac97_bus               12730  1 snd_ac97_codec
snd_pcm               102099  2 snd_ac97_codec,snd_intel8x0
snd_page_alloc         18710  2 snd_intel8x0,snd_pcm
snd_timer              29482  1 snd_pcm
snd                    69238  4 snd_ac97_codec,snd_intel8x0,snd_timer,snd_pcm
soundcore              12680  1 snd
:~$

Additional information for troubleshooting

What is the output of the following?

:~$ locate snd-hda-intel

Several users on other posts were able to get this audio chipset working by editing /etc/modprobe.d/alsa-base.conf

nano /etc/modprobe.d/alsa-base.conf

And add the following line:

options snd-hda-intel model=generic

Posts referenced/researched:

  • First of all, thank you for answering. I tried all the commands you posted and I got no output. I also tried adding the line in alsa-base (and rebooting) but it didn't work. – marlanbar Aug 8 '14 at 19:21
  • @marlan21 - I added an additional solution and posted it as a separate answer. Here we take the approach that some packages may be mis/unconfigured. – Crusty Barnacle Aug 8 '14 at 23:05
0

Alternate method to fix sound (due to misconfigured/unconfigured packages after install/update/upgrade).

  • Fix packages that are not properly configured

:~$sudo dpkg --configure -a, then do a :~$sudo reboot

Post referenced: It's F.O.S.S., Fix No Sound in Ubuntu

  • It didn't work either. Mmm I not exactly sure how this happened, I tried to update alsa installing the driver found in the realtek website. Perhaps it's better to reinstall Ubuntu from scratch don't you think? – marlanbar Aug 8 '14 at 23:53
  • @marlan21, maybe that is the easiest option. But, why are you installing realtek drivers for an Intel chipset? – Crusty Barnacle Aug 9 '14 at 0:01
  • I wanted to split the sound of the front connectors with the ones in the back. I read in a website that this was the way to do it, but I guess it was wrong. – marlanbar Aug 9 '14 at 0:37
0

Several users on other posts were able to get this audio chipset working by editing /etc/modprobe.d/alsa-base.conf:

nano /etc/modprobe.d/alsa-base.conf

And add the following line:

options snd-hda-intel model=generic

This worked for me on a Philips Freevent x55, although I had to use sudo gedit instead of nano.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.