0

I recently installed squid along with Dan's Guardian. Ever since I got them up and running I've been getting errors when I try to run apt-get update. The errors look like this:
W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-updates_restricted_source_Sources Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-updates_multiverse_source_Sources Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-updates_restricted_binary-amd64_Packages Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-updates_multiverse_binary-amd64_Packages Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-updates_restricted_binary-i386_Packages Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-updates_multiverse_binary-i386_Packages Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-security_restricted_source_Sources Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-security_universe_source_Sources Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-security_multiverse_source_Sources Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-security_restricted_binary-amd64_Packages Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-security_multiverse_binary-amd64_Packages Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-security_restricted_binary-i386_Packages Hash Sum mismatch W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty-security_multiverse_binary-i386_Packages Hash Sum mismatch

I run ubuntu 14.04. Anybody have an idea how to fix this? `

0

So do you still has direct Internet connection, or through Squid only? Apt-get needs to be configured to work through proxy, as well as any other software. In /etc/apt/apt.conf add

Acquire::http::Proxy "MYDOMAIN\MYNAME:MYPASS@MY.PROXY.COM:MYPORT"
0

I found someting similair, running this code did it or me:
export {http_proxy,https_proxy,ftp_proxy}="http://127.0.0.1:3128"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.