13

I have Ubuntu 14.04 installed on my laptop. When I have my laptop plugged in to my tv to watch a movie, the screen goes black after exactly 5 minutes. I have to move the mouse, to see I'm at the login screen like this

enter image description here

I'm wondering how can I disable this screen from popping up entirely?

I have already went to System -> Power Management and put everything at Don't suspend / Do nothing. This did not work!!

2

3 Answers 3

16

Change both "System Settings -> Brightness & Lock" and "System Settings -> Power Settings"

2

If someone is using Gnome, this can be accomplished using the Caffeine Gnome extension

https://extensions.gnome.org/extension/517/caffeine/

I'm not sure if Unity has something similar or not.

2
  • I think this is a good answer, but you might want to expand it with information about how to install/enable Caffeine on an Ubuntu system that's running GNOME. Aug 11, 2014 at 23:53
  • You visit that page from Firefox while running gnome shell and you should see a button towards the top left that says "off". click the button to turn it to the 'On' setting. Aug 12, 2014 at 15:27
1

I had the same problem on my Xubuntu and I did this:

xset -display :0 s off -dpms

It is not persistent though and since I dont want it to be I did this:

Add this command to your startup applications:

sh -c "sleep 30; xset -display :0 s off -dpms"

You can change the sleep time to whatever you want even remove it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .