1

This question already has an answer here:

We were trying to Install Ubuntu 14.04 In Dual Boot Mode With Windows 8.1 UEFI in my new HP laptop. The installation of Ubuntu was finished successfully. But when I rebooted (with secure boot disabled) it is not showing any GRUB menu and directly going to Windows.

So I tried Boot-Repair. For this I plugged our USB drive back in and reboot so that the live version of Ubuntu runs again. Then I used following command for boot repair.

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)

Then I repaired the boot with the launched Boot-Repair window. But it end with the following error message.

"An error occurred during the repair.

Please write on a paper the following URL: http://paste.ubuntu.com/7982274/

In case you still experience boot problem, indicate this URL to: boot.repair@gmail.com

You can now reboot your computer. Please do not forget to make your BIOS boot on sda (1000GB) disk!"

I also send a mail to the given mail ID. Please suggest a method to solve my problem. Thanks.

marked as duplicate by Luis Alvarado Sep 4 '14 at 19:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

I was unable to find any obvious errors in the log you attached, although admittedly I'm not that familiar with boot-repair. But I think the following might solve your problem, as it did for a friend who also had a UEFI HP laptop skipping grub:

  1. Boot into windows and open a command prompt as an administrator
  2. Execute the following: "bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi"

Although I feel I should note that according to boot-repair you're either hibernating windows instead of shutting down, or using hybrid shut down. Doing so will prevent you from accessing the files on your Windows partition from inside Ubuntu. If you don't care that's fine, if you do care then don't hibernate windows and turn off hybrid shutdown as described below.

  1. Open "Control Panel" > "Power Options" > "Choose what the power buttons do"
  2. Click "Change settings that are currently unavailable"
  3. Under "Shutdown settings" uncheck "Turn on fast startup", then click "Save"
  4. If you don't see "Turn on fast startup" it is already disabled

If the first set of steps doesn't fix the problem, you'll have to wait for an answer from someone with more detailed knowledge of boot-repair and grub.

  • @TheSchea Thank You thankyou very much.... :-) – R S John Aug 8 '14 at 18:48
  • @TheSchea Thank You... thankyou very much.... :-) I was struggling with this problem for the past few days.... now it has been solved thanks... – R S John Aug 8 '14 at 18:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.