When I use my laptops HDMI on a TV the TV overscales the picture (~5-10% is missing at the edges). There is no option on the TV (sporting a 720p resolution btw). The comp is running Intel HD Graphics 4000.

There is no options to compensate for this in the Ubuntu Settings and I been playing around with xrandr (using transform/scale) but nothing seems to work. The plethora of guides on this subject using transform doesn't work me. This is so annoying since it seems to be so easy to fix ("compressing"/resizing the image to fit the screen) but I have run out of ideas. Setting custom resolutions doesn't help (still parts out of the screen). Its basically 2 clicks away to fix in windows but in ubuntu it seems impossible...

Would be really happy if someone could help me out or have any ideas what I could try! Thanks.

  • with xrandr did you try xrandr --output HDMI1 --transform 1.05,0,-35,0,1.05,-19,0,0,1 – mchid Aug 8 '14 at 1:10
  • Yes, this aligns the picture to the top left corner but doesn't change the size of it (or at least not enough). I still can't see the top right part of my screen (it cuts it before the clock and the settings wheel) and also im missing parts of my bottom screen. It might be a little bit better though. I have played around with the transform setting a lot, but for some reason I cant get the scaling part (1.05) to work the way I want. – SodR Aug 8 '14 at 9:56

Okay, if you haven't already tried these, check it out

xrandr --output HDMI-1 --set underscan on
xrandr --output HDMI-1 --set "underscan hborder" 40 --set "underscan vborder" 25

Another one I came across was this:

xrandr --output HDMI1 --transform 1.05,0,-35,0,1.05,-19,0,0,1
  • I dont even have VGA out on my laptop so this wont help im afraid. – SodR Aug 8 '14 at 0:58
  • @SodR I updated the post if any of these help – mchid Aug 8 '14 at 1:16
  • 2
    I tried those. The first one that mentions the parameter "underscan" or "overscan" isn't recognized by xrandr or at least not supported by either my device or xrandr anymore. It gives this output: X Error of failed request: BadName (named color or font does not exist) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 11 (RRQueryOutputProperty) Serial number of failed request: 41 Current serial number in output stream: 41 – SodR Aug 8 '14 at 9:44
  • The second line aligns the top left corner by moving it 35 pixels to the right and 19 pixels lower, but the actual picture isn't any more compressed. This means all gained "vision" in the top left corner is now lost in the bottom right where the picture have moved an equal amount of pixels. – SodR Aug 8 '14 at 9:51
  • last command actually worked for me – Postadelmaga Nov 14 '15 at 12:34

I ran into this issue and used a combination of shrinking the framebuffer and then realigning the top left corner. The other answers depended on specific features provided by the display which some older displays don't have. (like mine)

xrandr --output HDMI2 --fb 1240x700 --transform 1,0,-20,0,1,-10,0,0,1

So, to read this, my TV overscans the picture by 20 pixels on the sides and 10 pixels on the top and bottom. So "shrinking" the picture, but not the resolution, by 40 width and 20 height, then realigning the top left corner did the trick for me.

You'll probably have to play around with the numbers since it seems different manufacturers' overscan varies in pixel loss. My TV seems to overscan less than many of the examples I found googling the subject.

Also, when playing with the numbers, doing a --transform none resets any change you make back... which might help.

/etc/rc.local:

intel_panel_fitter -p A -x 1200 -y 670

~/.xprofile:

xrandr --output HDMI1 --transform 1.0,0,+1,0,1.0,+2,0,0,1
  • 1
    This can be a good answer, if you describe what those commands are supposed to do and why they're placed in those files. – David Foerster Dec 1 '14 at 20:24
  • This intel_panel_fitter command worked for me on my Sony Bravia KLV-V32A10 – jeremy Sep 30 '16 at 11:29

The original answer xrandr --output HDMI-1 --set underscan on works!

It might not work on the first try if you just copy and paste this. The reason is that you might not be on HDMI-1 on your system. I tried this and I got error of failed request bad output (invalid parameter). I typed xrandr by itself and it gave me a bunch of display data and I noticed my device is HDMI-0. I then typed the command as xrandr --output HDMI-0 --set underscan on and whoop there it was fitting perfectly. I hope this helps someone.

Are you absolutely certain there is no option on the TV? I too have Intel HD Graphics and had the same problem, until I changed "Theater Settings" from "Full" to "Native". On my TV this was at the bottom of the picture menu. Other TVs sometimes label it as "Widescreen Settings" or similar.

  • Yes its an old TV without that option unfortunatly. – SodR Aug 8 '14 at 0:57
  • Darn :( thought I should mention just in case you only messed with the resolution and not the Theater settings. Good luck though! – TheSchwa Aug 8 '14 at 1:02

Here's what fixed it for me. I had this problem on Ubuntu 14.04, which also jettisoned fglrx after an upgrade.

My monitor (Viewsonic) has two input settings, 'PC' and 'AV'. For some reason the input setting had been switched to 'AV', and that's where I was seeing the overscan. Switching it to 'PC' fixed the problem.

So the fix involves using the monitor hardware keys and going through the monitor settings menu to make the change.

I know this thread is old, however if anyone else comes across this issue; the problem could be on the TV. On a Series 7 Samsung TV:

  • Press the "MORE" button on the remote
  • TOOLS > Picture Size
  • Select "Screen Fit"

Picture displays properly now.

I struggled with this for a while until I found this blog post.

Basically, check the properties on your display using:

xrandr --prop

I didn't have the underscan options some people have mentioned, but what I did have was the 'force-dvi' property under 'audio'.

xrandr --output HDMI-2 --set audio force-dvi --mode 1920x1080

This worked perfectly, and disabled the overscan. One slight downside - this fix stops audio from coming through your HDMI cable, but I use external speakers so not really a problem.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.