0

I have a 2TB Western Digital HDD with one partition formatted as HFS+. I tried pretty much everything to make it readable (not even writable) from Ubuntu Server, but had no success.

I tried:

  • changing my linux uid to 501
  • installing hfsprogs and hfsplus
  • disabling journaling from OSX Disk Utility

I'm blocked.

The root problems seems to be that linux isn't able to read a partition table on the hard drive: when I run sudo fdisk -l, it tells me that

/dev/sdc doesn't contain a valid partition table

That said, I'm obviously not able to mount anything since the OS only knows about /dev/sdc, no partitions like /dev/sdc1.

How can I proceed? I have access to an OSX machine at all times if it's necessary.

0

Try adding hfsutils, hfsutils-tcltk, libhfsp-dev, and maybe tmfs will bring in some dependency that will help with your situation:

sudo apt-get install hfsutils hfsutils-tcltk libhfsp-dev tmfs
  • No luck here. Seems like there's some problem with partition tables. – whatyouhide Aug 8 '14 at 9:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.