65

I have recently updated my laptop OS from Ubuntu 12.04 to 14.04

After updating the OS, my laptop's input device ie., microphone is not working.

Earlier it was working with Ubuntu 12.04.

Also there is no sound input device driver detected

Sound setting

I am using Dell Vostro 1014.

after running command $ gstreamer-properties, output is:

gstreamer-properties

I think my microphone is working but is not being betected by ubuntu as in above screenshot.

But after running Pulse Audio Sound Control, it shows input sound progress, it means input device is working but not being detected. Even by Sound Recorder. Pulse Audio Sound Control

After running alsamixer the output is: alsamixer

8
  • Updated my question with the output asked for
    – Anuj TBE
    Aug 7 '14 at 17:20
  • gstreamer plugins are already installed, as click the link opens software-center and asks to remove instead of install
    – Anuj TBE
    Aug 7 '14 at 17:33
  • I think there is some setting to select sound input device/profile. But, I don't know where it is.
    – Anuj TBE
    Aug 9 '14 at 7:00
  • 1
    What outputs do you have available? Have you checked if your onboard sound card was disabled at the BIOS? Apr 5 '15 at 11:42
  • 2
    I have windows 7 parallel to ubuntu. and sound input is working good in windows. If it was disabled in BIOS it must not work with windows as well. This issue is only with Ubuntu
    – Anuj TBE
    Apr 5 '15 at 13:18

11 Answers 11

56

I had a similar problem - no sound input device driver detected. I used pavucontrol, as explained in this Ask Ubuntu answer and it solved the problem:

  • Install pavucontrol: sudo apt-get install pavucontrol
  • Run:pavucontrol
  • Go to the Input Devices tab
  • Click the lock icon to unlock the channels
  • Under Port, select the correct microphone (front or rear)
3
  • 1
    The problem was almost fixed after installing pavucontrol (all devices went mute). One step was left for me and I struggled a lot trying to figure out why I was getting false positives: Re-plug your I/O sound devices to get them working again. Nov 16 '19 at 9:28
  • no working with my Plantronics WO350. Its fisible as "Savi Office Base Station Analog Sterio" and looks working, but still nothing to hear
    – SL5net
    Feb 12 '20 at 17:11
  • Thanks a lot, pavucontrol did the trick for me, only install and the mic was working, USB Kungber mic, on Linux Mint 20.2.
    – Raberg
    Sep 15 at 19:46
16

try this in terminal for no sound:

sudo alsa force-reload

restart device and check if sound is workin?

if it doesnt do this:

sudo apt-get remove --purge alsa-base pulseaudio

sudo apt-get install alsa-base pulseaudio

Restart device and check ..This should probably do the job!

3
  • I tried this, but still nothing happend....
    – Anuj TBE
    Aug 9 '14 at 5:29
  • 22
    These commands will also remove some important dependencies that may break Ubuntu. Type in the command sudo apt-get install ubuntu-desktop to reinstall the removed files. Mar 29 '16 at 22:09
  • 2
    Warning!!!!! what @authentictech said is correct, remember that. Jun 16 '16 at 14:38
10

Open a terminal and issue the command alsamixer you will get a screen like this:

alsamixer

use the right arrow to highlight the Front Microphone

if it's muted as shown above, hit the 'M' key to toggle Mute off.

then use the up arrow to increase the gain (sensitivity) your end result should look similar to this. Hit the Esc key to exit. Your Microphone should now work as advertised.

alsa-gain-up

5
  • 1
    Can you please elaborate on how to use alsamixer and how to open it for those who don't know. A screenshot would improve your answer as well!!
    – v2r
    Aug 21 '14 at 15:36
  • @NoTime Answers like this are not more appropriate as comments. Aug 21 '14 at 16:20
  • @EliahKagan you are right I should have just put I am unsure if this would solve any issue, already downvoted and flagged as low quality.
    – No Time
    Aug 21 '14 at 16:24
  • 5
    In my case, after running alsamixer, there are only three columns of Master,PCM and Beep. There is no column for microphone.
    – Anuj TBE
    Aug 22 '14 at 16:38
  • it worked! but You can barely hear the sound! May 3 '18 at 17:07
7

Had the same problem. Solved it like this:

  • Run pavucontrol from the terminal window.
  • Check microphone level and mute switch in tab Input Devices.
  • Open tab Recording.
  • In parallel, start the recording function in the wanted application. E.g. press record in Audacity or start a test call in Skype.
  • In the Recording tab of pavucontrol, now a source selection becomes available. Select the right one. Worked for me.

To me it is (was) confusing that the source selector is not always present in pavucontrol.

1
  • @JuanAntonio, Could you please review my edits and also review the editing help to improve the readability of your own edits in the future... ;-)
    – Fabby
    Jan 17 '17 at 21:39
5

Goto PulseAudio volume control --> Configuration, choose "Analog Stereo Duplex" under the Profile section.

Restart your machine.

*Tried in Ubuntu 16.04 LTS

2
sudo nano /etc/modprobe.d/alsa-base.conf

add this line:

options snd-hda-intel index=0 model=laptop-dmic
1
  • This made a microphone unit show up in Sound settings ("Internal Microphone Built-In Audio"), but it is stuck at 0% volume and greyed out. I'm on Mint 20, i.e., Ubuntu 20.04, and running a Dell Inspiron 7708 laptop. Mar 21 at 18:29
1

The following might work for you:

  1. Run gksudo gedit /etc/modprobe.d/alsa-base.conf on terminal (if you have no access to a graphical interface in the moment, use sudo nano instead of gksudo gedit.
  2. Add options snd-hda-intel position_fix=1 or position_fix=2 to the end of the file.
  3. Reboot

Sources: http://ubuntuforums.org/showthread.php?t=1893142 and https://wiki.ubuntu.com/Audio/PositionReporting

0

I had the same problem. I found the solution after I upgraded to 16.04, but I think it works on 14.04 too! In Skype click "Open PulseAudio Volume Control". From there on move to "Input Devices" and change the Port. By some miracle my microphone started working after I changed my port to "Microphone (unplugged)". Good luck!

0

For me everything looked correct, input device was selected correctly however I was unable to use the inner or the external mic. I solved it by enabling the webcam using the Fn keys. Apparently they are enabled and disabled by the same Fn key.

0

If you don't see your Microphone in the Port selection under the input devices in pavucontrol: use pavucontrol -> configuration -> built_in Audio. Check if you have * Output + * Input choosen in your profile, otherwise your microphone isn't shown in the input devices section and cannot be used.

-3

I had a similar problem on 14.04, sound input source was blank in the 'Sound Settings'. I did the following, what did the trick is installing 'Audacity', for more info check the following link

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo apt-get install audacity
2
  • 8
    Doind this somehow completely screwed with my system. Now I don't even have sound settings or a sound icon on the panel. Fixed it after reading askubuntu.com/q/453440/48105 and reinstalling ubuntu-desktop. Apr 5 '15 at 11:35
  • Purging packages should be done with great trepidation. It can kill things that you'll have a lot of trouble getting back.
    – Paul A.
    Aug 11 '20 at 1:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.