3

My touchpad is not recognized (is not present in the xinput list) as a PS/2 device or a USB device after installing Ubuntu 14.04. My computer is an Ultrabook that I bought with Windows 8, the touchpad worked perfectly in that OS. Ubuntu is installed as the only OS, root is in a 32GB SSD and /home in a HDD 500Gb. The Ultrabook comes with UEFI, I disabled FAST BOOT, and boot in dual mode (UEFI and Legacy). I can use an external USB mouse. My guess is that the device is disable or not recognized to work in Legacy. Could it be possible? Any ideas for detecting the Touchpad? Tanks!

1

Try the following

cat /proc/bus/input/devices | grep Name

Output should include > Elantech Touchpad

If so download the following

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442/+attachment/3941591/+files/psmouse-elantech-x551c.tar.gz

Open a terminal, and follow these steps

cd ~/Downloads sudo dkms ldtarball psmouse-elantech-x551c.tar.gz sudo dkms install -m psmouse -v elantech-x551c

sudo rmmod psmouse sudo modprobe psmouse

HTH

Reference

- Ubuntu activate multi touch on elantech

  • Glad, I was able help, if you would accept this as an solution – Mahendra Gunawardena Aug 19 '14 at 22:49
1

I had this problem in a similar machine (EXO Nifty T7181). The solution above didn't work for me, and after a couple of days of research, I found this bug in the kernel, so I made a patch, recompiled the kernel and hopefully it worked.

I don't know if this is the right place to post this information, if not, I apologise, but it is so frustating just to get a new laptop, and you can't use the touchpad.

Hope it helps!

More information about how to recompile:

Disclaimer: I'm not a Kernel expert, quite the contrary, so I don't know if this is the best way to do it. I got this information from this link

To recompile the kernel, I followed these steps:

  1. Get the kernel code, through apt or just a checkout from github

  sudo apt-get source linux-image-uname -r 

  1. Donwnload the bugzilla patch and save it in a file named elantech-final.patch

  2. In the case you downloaded the kernel sources through apt, you would have a tar.gz file in your $HOME folder. Unzip it.

  3. Copy the patch to the kernel sources folder

  4. Now, to actually patch the kernel, you should run

  cat ~/elantech-final.patch | patch -p1 

  1. This step is to build the new custom kernel as a deb package

make oldconfig
make clean
make -j getconf _NPROCESSORS_ONLN deb-pkg LOCALVERSION=-custom

  1. After that, you just have to install the new Kernel from the .deb
    sudo dpkg -i linux-image- YOUR IMAGE FILE.deb
    sudo dpkg -i linux-headers- YOUR HEADERS FILE.deb
    
  • could you expand how to apply the patch? Your ultrabook its the one with tactile display? The display works? – Guillermo Olmedo Mar 4 '15 at 15:58
  • 1
    Hey Guillermo, yes, the ultrabook is the one with the tactile display. The display is working, but it is not recognizing some basic gestures like the two-finger scrolling. Also, the mouse pointer goes crazy randomly, and I couldn't figure out why yet. I wrote how I recompiled the kernel, I'm not an expert, so be careful, but at least, it worked on my machine. Good luck! – Juan Lagostena Mar 5 '15 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.