15

When I try to shut down my computer, it hangs at the shutdown screen and these are the only lines I can see:

wait-for-state stop/waiting
Stoping GNUstep distributed object mapper: gdomap.
* Stopping rsync daemon rsync [ OK ]
* Stopping Speech Dispatcher speech-dispatcher [ OK ]

And thats all.

I'm using gnome 3.10 (had 3.12 but downgraded because of some problems) if it has something to do with that.

Rebooting the computer works; it doesn't hang.

10 Answers 10

13

In my case these simple steps worked for me fine:

  1. Press Ctrl+Alt+T to go to a terminal and type:

    sudo gedit /etc/default/grub
    

    This will open the grub config file. Change the line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    to:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force apm=power_off"
    

    Then save & close it.

  2. Type in the same terminal:

    sudo gedit /etc/modules
    

    This will open the modules config, just add the following:

    apm power_off=1
    

    and save the file.

  3. Next type in the terminal:

    sudo update-grub
    

Source

  • @Fabby you are right, thank you. I have added the steps =) – Uroš Podkrižnik Jan 14 '16 at 16:07
  • Much better! And an edit and an upvote! Could you please review my edits and also review the editing help to improve the readability of your answers in the future... ;-) – Fabby Jan 14 '16 at 16:32
  • 1
    I believe acpi=force belongs inside the quotes, as I have seen many places elsewhere (see one example). The answer below also has the apm=power_off part within the quotes. – Nateowami Jun 26 '16 at 13:03
7

Ubuntu doesn't shutdown properly or hangs at shutdown ?

Issue faced While installing Ubunutu 14.04 in Dell XPS 15Z Laptop

Open the file /etc/default/grub with text editor of your choice, and with admin privillege. Could be done with gksu gedit /etc/default/grub for GUI text editor or sudo nano /etc/default/grub for command-line access.

Find the following line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Replace it with the following:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq acpi=force apm=power_off quiet splash"

Save and close the file. Back in the terminal execute :

 sudo update-grub

Now, when you shutdown, it should work.

  • Hangs at shutdown. I tried this but same problem persist. – user313246 Aug 7 '14 at 10:24
  • For Razer Blade 14 your solution helps. Thanks. I dropped acpi=noirq as it makes no difference in my case. – topr Jun 6 '15 at 11:58
3

I just deleted quiet splash from this line in /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and ran sudo update-grub

and it's never hung at shutdown again

  • I deleted and now my laptop don't get stuck at shutdown/reboot. Thanks. – Mustafa Chelik Apr 14 '15 at 21:36
2

I'm using Lubuntu 16.04.1. I tried several methods including: editing /etc/default/grub, run sudo swapoff -a before shutdown, etc... But none of those worked for me.

Turning off USB 3.0 legacy mode in the BIOS worked for me.

1

I tried to grub changes with no success. I had to use sudo shutdown -h 0 (so with -h) to make it work.

If I forget -h, the system hangs with me potentially far away, so I made an alias for it (normally not a good idea to alias builtin commands but I feel this is important).

alias sudo='sudo '  # note the space, that's what makes sudo recognize aliasses
alias shutdown='shutdown -h'
1

I had the same issue with the shutdown on Ubuntu (15.10 and 16.10). With debug enabled in GRUB I could see that the laptop crashed right after 'Reached target Shutdown'

GRUB_CMDLINE_LINUX_DEFAULT="debug"

I also tried various GRUB options and even to create a service that powers off the USB.

If you have USB 3.0 you could try to disable them from BIOS (I could not do that on my ASUS X540SA due to few settings in BIOS)

For me, the solution was to upgrade the kernel. I used 4.5.3 on Ubuntu 15.10 (anything greater than this will crash the OS after login) And 4.7 RC3 works on Ubuntu 16.04.

Previously I had Linux Mint 17 installed and it didn't have issues on rebooting/shutdown.

  • Holy shit! Thank you so much! I've been trying to fix this for days now. Disabling Pre-OS USB 3.0 Configuration from my BIOS settings fixed it. – Sheharyar Jul 25 '16 at 18:05
0

I had the same thing happen to me on my ASUS laptop and tried every method to counter it under the sun. The one that got the furthest was updating the kernel to 4.2.3, so if you want to give that a try then click here and follow the instructions.

Failing that, you can always fall back on SysRq, which is what I did. If you intend to use SysRq then really you should follow the REISUB steps, but really, if you need to do it often like I did, then all but B (or O in our case) don't really matter.

Hold down the Alt+Prt Sc/SysRq+Shift keys and type in REISUO, making sure to wait about 5-10 seconds between each one and your computer will shut down.

Explanation:

 R - Forces capturing of the keyboard
 E - Terminates all processes
 I - Kills all processes
 S - Syncs all mounted drives
 U - Remounts all drives in read-only mode

Then either:

 B - Reboots the system
 O - Shuts down the system

It's because of the long wait needed between each entry that I cut down on the unnecessary ones; plus, most are only needed if you lose control over the system. So if you try to shut down manually and it freezes, as it is want to do, follow REISUO ... otherwise just use O.

(Remember that it won't happen right away, so don't keep pressing it to make it work faster; just be patient).

As an additional note: some computers may use different key combinations, such as Alt+Fn+Prt Sc/SysRq. There are more details here on the Wikipedia page with alternate patterns you can try if the original doesn't work.

Hope this all helps.

0

I had this very same problem and nothing suggested was working. I finally figured out that the system was set to boot in using LEGACY and not UEFI Secure. Once I changed it to UEFI it worked perfectly!

0

I had the very same problem and it took me 3 days to solve it.

I am using a Lenovo B50-10. The installation of Ubuntu 14.04 did not cause any problems until I wanted to restart the computer to finish the installation progress. The display turned black and the computer wouldn't do anything. Soon I figured out that it would't shut down either. The hard drive turned off but the display froze showing the ubuntu logo with the dots.

So I tried modifying the boot options by editing the

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

line and applying the solutions that are mentioned in the answers above.

Then I figured out that I installed Ubuntu in the legacy mode and this may be a reason. So I changed the BIOS mode to UEFI and installed it in the UEFI mode. Surprisingly I now could stop Ubuntu from hanging on shutdown/resart by editing

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"

Unfortunately this modification caused that I had no wifi connection anymore. So it wasn't a solution really and I considered updating the BIOS and the kernel. But without a Windows product key and bloody linux beginner as I am I didn't know how.

But finally I solved the problem by applying this solution:

Go to bios and change "OS Optimized Defaults" and set it to "Enabled". Then hit "Load default settings".

This was the solution that worked for me. So I didn't need to update the firmware or the kernel.

-1

I still have the same problem, despite following the advices,

Here is the output of

sudo gedit /etc/default/grub

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force apm=power_off"
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=bios"
GRUB_CMDLINE_LINUX=""

And output of

sudo gedit /etc/modules

lp
rtc
apm power_off=1

Thanks,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.