0

I bought a Dell Inspiron 14 5000 series and dual booted Windows 8.1 and Ubuntu GNOME 14.04. The brightness would not change, so I booted with kernel parameter acpi_backlight=vendor and it worked. I later had to return that specific unit because of a hardware defect for another one.

With the second (current) unit I installed just regular Ubuntu 14.04. I tried to use the kernel parameter acpi_backlight=vendor with it, but with quiet splash acpi_backlight=vendor all it gave me was a black screen. I booted without quiet splash and it froze at allocating swap space.

Why is it refusing to boot?

I also tried adding acpi_osi=Linux to acpi_backlight=vendor. Still wouldn't boot. acpi_osi=Linux on its own does not have any effect.

  • What is the exact output on the screen at this point: "I booted without quiet splash and it froze at allocating swap space." ? – amanthethy Aug 7 '14 at 2:25
  • Is it relevant? It was a message about allocating ~ 8 gb of swap space (I have 8 gb of RAM) and then it froze – Aristides Aug 8 '14 at 14:25
  • It's relevant because that's where it froze. This could be completely unrelated to your card and/or the swap. Chances are the clue is in whatever messages are on the screen. Add a verbose paramater so you can see everything that's happening at boot and then post a picture here and maybe someone will figure it out. – amanthethy Aug 8 '14 at 21:37
0

This happened to me once and I found an answer here: How do I adjust the screen brightness on an Acer Aspire One D270?

It was about brightness issues and this fixed it for me:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux i915.i915_enable_rc6=1"

There are a lot of other parameters suggested as well.

  • Did not do anything. – Aristides Aug 7 '14 at 1:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.