Ever since the Geforce 2 days, I've been installing the Nvidia binary graphics drivers on my Linux desktop machines. I've always used Nvidia cards so that this was possible. After a stint with a MacBook that I've had to return, I tried a fresh install of Ubuntu 14.04, and activating the Nvidia drivers via Synaptic's 3rd-party driver switcher, as I've done many times in previous versions. It sat there doing nothing, so I finally killed it. It said it switched, but it didn't.

I tried a couple more times with Synaptic, to switch back to the nouveau driver, and then back to the Nvidia driver. It wouldn't work, and the system continued running the nouveau driver upon reboot.

I tried using the Software Center to do the same thing. It looked like it worked, but it didn't. The system was still using the nouveau driver on reboot.

I tried the "stable" X drivers PPA, and installing the nvidia-331 package by hand. Didn't work; nouveau was still active.

I tried the "experimental" X drivers PPA. Same thing.

I tried blacklisting the nouveau driver by hand (as other posts here indicate would happen when installing an nvidia driver), removing the X driver package, AND physically removing the only copy of the kernel driver I had, and it STILL came back on reboot. Did it rebuild on startup!?

For two hours, I've hassled with this, and I'm getting too old for it. I consider myself pretty fluent in "Linux." After all, I've bashed my head against it for 20 years, through Slackware, Red Hat, SuSE, Gentoo, and now Ubuntu. This issue has left me flummoxed. It can't be this bad. How can none of this have worked?

Lots of posts I've found are clearly out of date, and no longer apply to 14.04. The official Canonical FAQ on this topic lists being able to run something called jockey-text, which is gone in 14.04, replaced with another tool that doesn't switch drivers around.

Any recommendation for running nvidia-xconfig is also DOA, since that tool doesn't get installed with any of these methods I've tried above. I finally downloaded the actual driver from Nvidia to get a copy of the command to make an initial xorg.conf file so that I would know that "nvidia" is the driver being referenced, but the system still loaded the nouveau driver.

Is that it? Is there no way that I can run an Nvidia card (with the binary driver) on Ubuntu now? Do I have to switch distros to play Civilization on Linux?

  • 2
    Take a look at my answer here, see if it helps. – Mitch Aug 6 '14 at 19:08
  • Sort of. I purged the x-edgers PPA, and used the Software Center to switch to the nouveau driver, then used it again to switch to the nvidia-331 driver. That worked. My take away is that the proprietary-driver-switcher in synaptic is currently borked, and manually apt-get'ting an nvidia package (and manually configuring the driver in xorg.conf) is no longer good enough to do all the changes necessary to switch away from using the nouveau driver. – David Krider Aug 6 '14 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.