2

I'm trying to install owncloud on CubieTruck, with armhf architecture.
When looking in Ubuntu Package site, it's listed as "all" architecture.
When running apt-cache show owncloud | grep Architecture on my x64 PC, I see Architecture: all as well.
When trying to find the package in my CubieTruck, I can't find it.

root@cubie:~$ apt-get install owncloud 
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package owncloud 

Output of apt-cache policy:

Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty-security/restricted Translation-en
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty-security/main Translation-en
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty-security/restricted armhf Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=restricted
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty-security/main armhf Packages
     release v=14.04,o=Ubuntu,a=trusty-security,n=trusty,l=Ubuntu,c=main
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty-updates/restricted Translation-en
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty-updates/main Translation-en
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty-updates/restricted armhf Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=restricted
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty-updates/main armhf Packages
     release v=14.04,o=Ubuntu,a=trusty-updates,n=trusty,l=Ubuntu,c=main
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty/restricted Translation-en
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty/main Translation-en
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty/restricted armhf Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=restricted
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports/ trusty/main armhf Packages
     release v=14.04,o=Ubuntu,a=trusty,n=trusty,l=Ubuntu,c=main
     origin ports.ubuntu.com
Pinned packages:

Am I missing something?

2
  • have you followed this guide: software.opensuse.org/download/… ?
    – kamil
    Aug 6, 2014 at 15:55
  • @kamil no. I'm mainly interested in finding the missing package in the ubuntu archives.
    – Nitz
    Aug 6, 2014 at 16:05

1 Answer 1

1

You don't have the universe section of the repos enabled. Note that the owncloud package is in the universe section.

To do this, you can either run sudo add-apt-repository universe or you can edit /etc/apt/sources.list and manually add in the universe section.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .