3

Problem

I have a custom wallpaper as my desktop background, but it doesn't show up on the login screen and the default Ubuntu Unity "greeter" is shown.

Past Cases

In the past, they used to show up on the login screen too. For example, my very first wallpaper was of Elsa from Frozen, and then something else from an anime Bleach. They showed up when I booted the PC and stayed there as I entered the password.

Clarifications

I haven't done any major changes to my system. It's Ubuntu 13.10 (don't give me that support has ended thing, it's merely a technical problem that can be solved). I also tried putting that picture in the Wallpapers directory (Home/Pictures/Wallpapers).

Why This is Not a Duplicate

How do I add customized wallpapers so they appear in the dynamic unity greeter? is about adding an image to the default directory so that they can be changed via Right Click>Change Desktop.

How to change login wallpaper? is about having a separate image for background and another for the login screen.

Gradients backgrounds gives default wallpaper on login screen. is about another default wallpaper and it not showing, instead having the default wallpaper.

Desktop Background doesn't show up on logon screen [duplicate] is a duplicate that leads to the first question I mentioned here.

And they're all I could find in the search.

1

I found a solution that might fit for you in the following question: Changing login screen wallpaper

They recommend using the following commands:

sudo -i
xhost +SI:localuser:lightdm
su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter draw-user-backgrounds 'true'
gsettings set com.canonical.unity-greeter background 'imagepath'
exit

replace imagepath with your actual image path and then it should work fine. Make sure that your path is correct, because otherwise it may result in a black background.

  • Will you make it a standalone answer please? It worked, and that question is not defining this problem. Thanks! – Abhimanyu Aug 6 '14 at 12:23
1

For me this is was a file permissions problem. I fixed this by setting image permissions in nautilus to:

Owner - Read and Write 
Group - Read and Write 
Others - Read only
0

The only way I could make this work in 16.04 was to have my custom wallpaper image masquerade as a default system wallpaper, as follows:

  1. As su, copy the image to /usr/share/backgrounds
  2. As su, edit /usr/share/gnome-background-properties/$(lsb_release -cs)-wallpapers.xml
  3. Copy and modify one of the "<wallpaper>" elements to register the new wallpaper.
  4. Save the file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.