2

My 12.04 is asking me to update the HWE layer, but when I've made it last time all my VM stopped working correctly because of a bug in the 3.13 kernel.

So I have reinstalled a clean 14.04 but the KVM machines still doesn't work.

At the end I have reinstalled the full system with a clean 12.04.5 LTS version that is still asking me to update the HWE layer.

I want to update the HWE layer to have the LTS support but I don't want to use the 3.13 kernel but continue using the 3.8 kernel.

If it's impossible, I have to remove Ubuntu and go on another distribution.

The KVM machines are fundamental to my work and I can't work without them. The 3.13 kernel is unusable with KVM machines (the CPU goes 100% and the disk LED remains on with the disk using the maximum I/O). The VM are very slow and mostly not usable (on a VM with Windows 7 the simple login can take 5 minutes when it takes 1 second with 3.8 kernel). With the 12.04.5 I can use the VM normally with a little CPU usage and a very low disk I/O profile.

So the problem is clearly the kernel 3.13 and I don't want to use it.

I found very annoying that for an LTS version the HWE is not maintained any more and that I'm forced to do an upgrade to an unusable 14.04 to be able to have the updates (I've found many other things that don't work well on 14.04, for example the gdm that has syntax errors in the service scripts).

So it's simple, I want keep the 12.04.5 until the next stable release but I don't want use the 14.04 because has not reached the same quality level of the 12.04 and I don't want to reinstall the system just to try if the VM works.

So how to remove the annoying HWE update messages and continue to use the 3.8 kernel with my 12.04.5 LTS? (keeping the security updates of course)

0

No, you can not both use an old unsupported kernel and have security updates for that kernel. No kernel updates means no kernel security updates. From https://wiki.ubuntu.com/1204_HWE_EOL:

Starting Aug 8, 2014 systems running 12.04.2 HWE, 12.04.3 HWE, or 12.04.4 HWE will no longer receive software updates for the kernel and, if you're running it, the graphics stack.

According to the kernel release schedule, 3.8 is already unsupported, so if you want an older kernel with security updates you will need to downgrade to Ubuntu 12.04.1 and the 3.2 kernel:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.