0

I am trying to install FFMPEG in Ubuntu 14.04. I got help to install FFMPEG installation In meanwhile I got an error

`bash: ./configure: No such file or directory`

I am getting this error when I try to run this command

./configure   --prefix="$HOME/ffmpeg_build"   --extra-cflags="-I$HOME/ffmpeg_build/include"   --extra-ldflags="-L$HOME/ffmpeg_build/lib"   --bindir="$HOME/bin"   --enable-gpl   --enable-libass   --enable-libfaac   --enable-libfreetype   --enable-libmp3lame  --enable-libtheora   --enable-libvorbis   --enable-libvpx   --enable-libx264   --enable-nonfree   --enable-x11grab

Here is the ls -la output:

m-usman@muhammad-usman:~/ffmpeg_sources/ffmpeg-0.9.2$ ls -la 
drwxr-xr-x 16 m-usman m-usman   4096 Aug  6 14:25 . 
drwxrwxr-x 10 m-usman m-usman   4096 Aug  6 14:38 ..
-rw-r--r--  1 m-usman m-usman 162704 May  3  2012 avconv.c
-rw-r--r--  1 m-usman m-usman  36942 May  3  2012 cmdutils.c
-rw-r--r--  1 m-usman m-usman   1284 May  3  2012 cmdutils_common_opts.h
-rw-r--r--  1 m-usman m-usman  11858 May  3  2012 cmdutils.h
-rw-r--r--  1 m-usman m-usman   3275 May  3  2012 common.mak
-rw-rw-r--  1 m-usman m-usman    421 Aug  6 14:34 config.fate
-rw-rw-r--  1 m-usman m-usman 137030 Aug  6 14:34 config.log
-rwxr-xr-x  1 m-usman m-usman 114524 May  3  2012 configure
-rw-r--r--  1 m-usman m-usman  18092 May  3  2012 COPYING.GPLv2
-rw-r--r--  1 m-usman m-usman  35147 May  3  2012 COPYING.GPLv3
-rw-r--r--  1 m-usman m-usman  26528 May  3  2012 COPYING.LGPLv2.1
-rw-r--r--  1 m-usman m-usman   7651 May  3  2012 COPYING.LGPLv3
-rw-r--r--  1 m-usman m-usman   1038 May  3  2012 CREDITS
drwxr-xr-x  3 m-usman m-usman   4096 May  3  2012 doc
-rw-r--r--  1 m-usman m-usman  68481 May  3  2012 Doxyfile
-rw-r--r--  1 m-usman m-usman 185387 May  3  2012 ffmpeg.c
-rw-r--r--  1 m-usman m-usman 107664 May  3  2012 ffplay.c
drwxr-xr-x  2 m-usman m-usman   4096 May  3  2012 ffpresets
-rw-r--r--  1 m-usman m-usman  41085 May  3  2012 ffprobe.c
-rw-r--r--  1 m-usman m-usman 159009 May  3  2012 ffserver.c
-rw-r--r--  1 m-usman m-usman    564 May  3  2012 INSTALL
drwxr-xr-x 13 m-usman m-usman  24576 May  3  2012 libavcodec
drwxr-xr-x  2 m-usman m-usman   4096 May  3  2012 libavdevice
drwxr-xr-x  4 m-usman m-usman   4096 May  3  2012 libavfilter
drwxr-xr-x  2 m-usman m-usman  12288 May  3  2012 libavformat
drwxr-xr-x 10 m-usman m-usman   4096 May  3  2012 libavutil
drwxr-xr-x  2 m-usman m-usman   4096 May  3  2012 libpostproc
drwxr-xr-x  2 m-usman m-usman   4096 May  3  2012 libswresample
drwxr-xr-x  7 m-usman m-usman   4096 May  3  2012 libswscale
-rw-r--r--  1 m-usman m-usman   2005 May  3  2012 LICENSE
-rw-r--r--  1 m-usman m-usman  19678 May  3  2012 MAINTAINERS
-rw-r--r--  1 m-usman m-usman   4459 May  3  2012 Makefile
drwxr-xr-x  2 m-usman m-usman   4096 May  3  2012 mt-work
drwxr-xr-x  2 m-usman m-usman   4096 May  3  2012 presets
-rw-r--r--  1 m-usman m-usman    164 May  3  2012 README
-rw-r--r--  1 m-usman m-usman      6 May  3  2012 RELEASE
-rw-r--r--  1 m-usman m-usman   3383 May  3  2012 subdir.mak
drwxr-xr-x  4 m-usman m-usman   4096 May  3  2012 tests
drwxr-xr-x  2 m-usman m-usman   4096 May  3  2012 tools
-rw-r--r--  1 m-usman m-usman      6 May  3  2012 VERSION
-rwxr-xr-x  1 m-usman m-usman   1419 May  3  2012 version.sh

How can I fix it?

4
  • Could you provide the ls -la output? Maybe there really is "No such file or directory" – CijcoSistems Aug 6 '14 at 11:01
  • Yes please check question again – Muhammad Usman Aug 6 '14 at 11:05
  • Maybe my request was a bit overkill, but we have a better context now :P – CijcoSistems Aug 6 '14 at 20:53
  • Please post the output of <configure head -n 1 | hd. – Gilles 'SO- stop being evil' Aug 6 '14 at 21:22
1

Permissions look fine

-rwxr-xr-x  1 m-usman m-usman 114524 May  3  2012 configure

But something is preventing it from executing. This can happen because of several reasons, most common are:

  1. Architecture mismatch. E.g. my Bash shell shown here:

    $ file /bin/bash
    /bin/bash: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.26, BuildID[sha1]=0x5bb332752cc304fa7fbb838bdf7d7766ffc7a8a1, stripped
    

    Would not run on a RaspberryPi (ARM) or any 32bit (x86) system:

    $ uname -a
    Linux raspberry 3.12.20 #1 PREEMPT Thu May 29 01:23:51 CEST 2014 armv6l GNU/Linux
    

    This does not seem to be the problem because as far as I remember, configure files are shell scripts, but it could be in other cases, so I thought it would be useful to point it too.

  2. Mount options prevent from executing files. You can check this with the mount command without options. In the following example I could run ~/executable.bin but not /run/shm/file.sh

    tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=1593900k)
    /dev/sda5 on /home type ext4 (rw,nosuid,nodev,nodiratime,relatime,user_xattr,barrier=1,data=ordered,discard)
    
  3. Other more advanced scenarios such as

    3.1 SELinux restrictions

    Again, this is not the case, the ls -l output would show a dot in the permissions column (-rwxr-xr-x.)

    3.2 ulimit constraints

    Not your problem, and probably the message error would be different (feel free to edit the post and remove this entry if you think it only adds noise to the answer).

PS: If you provide the output of mount too, we will check option #2.

0

You dont need to implement difficult compilation procedures to install FFMPEG in ubuntu. All the packages for FFMPEG are in Official Ubuntu Repository.

You can install them as:

sudo apt-get install ffmpeg ffmpeg-doc winff-doc winff-gtk2 checkinstall yasm texi2html libfaac-dev libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev libsdl1.2-dev libtheora-dev libvorbis-dev libx11-dev libxfixes-dev libxvidcore-dev zlib1g-dev frei0r-plugins-dev libdc1394-22 libdc1394-22-dev libgsm1 libgsm1-dev libopenjpeg-dev libschroedinger-1.0-0 libschroedinger-dev libschroedinger-doc libspeex-dev libvdpau-dev vflib3-dev librtmp-dev libva-dev libjack-jackd2-dev libass4 libass-dev libmodplug1 libmodplug-dev libvo-aacenc0 libvo-aacenc-dev libvo-amrwbenc0 libvo-amrwbenc-dev libopenal1 libopenal-dev libavcodec-extra-53 libavdevice-extra-53 libavfilter-extra-2 libavformat-extra-53 libavutil-extra-51 libpostproc-extra-52 libswscale-extra-2 libx264-dev libx264-123 x264 libxvidcore4 winff

** Remove the unavailable packages for 14.04 from the list(Will mention in the installation)

2
  • Thanks sir but |I get some other error different from previous :( like packages are not available etc.. – Muhammad Usman Aug 6 '14 at 11:40
  • 2
    Remove them from the list. They are not available for 14.04 – user308564 Aug 6 '14 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.