I have found quite a few topics within this problem, but didn't really find a clear answer. I have updated my Ubuntu. The update I have installed Ubuntu update center said it had some unothorized installs. I have read, that people get these messages, but what you need to do is run sudo apt-get update and then sudo apt-get upgrade. So that was what I did. After I restarted the computer, I received this "Internal system problem". Tried to restart computer quite few times, but still the same. The thing is that I can not see the desktop as well, no icons, no nothing.

1 Answer 1


A first attempt, the way would try personally:

Do you get a login prompt if you hold CTRL+SHIFT and hit F1 ? - if that is not possible, try to get into 'Recovery mode' from the grub menu (hit ESC immediately at the end of BIOS displays to see it, if it isn't shown automatically).

In recovery mode first do fsck, then
enable networking, and finally
root prompt.

After either of the above try
sudo apt-get check at the prompt.

If that goes well then follow up with
sudo apt-get update (will scroll a lot of text) and
sudo apt-get upgrade.

  • askubuntu.com/questions/85641/… is also relevant - it does contain things to try if the above doesn't help.
    – Hannu
    Aug 6, 2014 at 10:14
  • I could manage to turn the recovery mode and did the fsck without problems. Running Enable networking I had this error saying "couldn't din'd support for device at....(many numbers): not supported by any plugin. Running the root prompt I get error again. running sudo apt-get update would stuck somehwere at 8% and would move anywhere
    – user288690
    Aug 6, 2014 at 11:38
  • That means that you do not have a working network connection - you will not be able to (re)download new content/packages. I'd suggest you still go to the root prompt and try the remainder of what I have written above - it might actually fix at least the networking. If you still have trouble after it: Then also check the information behind the link ^-- in the first comment. Try to match what you see with the info and try out any recommendations/commands.
    – Hannu
    Aug 6, 2014 at 11:45
  • I tried your way again, it didn't work out. Tried the same command lines with CTRL+ALT+F2. the update and upgrade worked this time but didn't really help. The error that I had just after the update, was about the compiz. Maybe I can restore it somehow using CTLR+ALT+F2? Maybe reinstalling Ubuntu would help?
    – user288690
    Aug 6, 2014 at 12:56
  • Reinstalling Ubuntu might be the "easy" way, if it works out ;-) - but looking into the details of the trouble with compiz might be quicker - or not ;-)
    – Hannu
    Aug 6, 2014 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.