6

I am facing problem to enable wifi on my Lenovo G50-30 Below are the command out put please help me out

lspci | grep -i wireless:

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

nm-tool:

NetworkManager Tool

State: disconnected

- Device: eth0 
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        28:D2:44:81:36:0B

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan0
  Type:              802.11 WiFi
  Driver:            rtl8723be
  State:             unavailable
  Default:           no
  HW Address:        14:2D:27:21:8D:47

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 

nmcli nm:

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         disconnected    disabled        disabled   enabled         disabled  

sudo rfkill list:

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: yes
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
5

Blacklisting ideapad_laptop is not the best solution, because some features like Fn buttons may be disabled too. Here is the bug report

I made a patch that fixes this issue. Before this patch reaches stable kernels you can use a patched module from my ppa. Install it this way:

sudo add-apt-repository ppa:hanipouspilot/ideapad-laptop
sudo apt-get update
sudo apt-get install ideapad-laptop-dkms

If you already blacklisted ideapad_laptop, you can undo it by

sudo rm /etc/modprobe.d/blacklist-ideapad.conf

Update: The patch has been accepted upstream and already reached Ubuntu kernels. The fix is in kernel 3.19.0-26. The next kernel update will fix the issue for Ubuntu 15.04 and 14.04.3.

After that the package and the PPA can be removed by

sudo apt-get purge ideapad-laptop-dkms
sudo add-apt-repository -r ppa:hanipouspilot/ideapad-laptop

Update For those who uses kernel 3.19 this ppa can be removed since 3.19.0-26 kernel includes this patch.

Now the issue is fixed in all Ubuntu kernels.

  • I am using 15.04 and did this. I hope they will fix it asap – wobsoriano Aug 16 '15 at 15:57
1

try removing the ideapad_laptop module

for one time test:

sudo rmmod ideapad_laptop

for working after reboot:

echo "blacklist ideapad_laptop" | sudo tee -a /etc/modprobe.d/blacklist-ideapad.conf

Source: praseodym (german) ubuntu-forum.de

Proove :

we have 2 of those laptops here and i had the same issue, it was fixed by this.

I tested the 14.10 Development version and 14.04.

Some do say the never kernel version (3.15 onwards) should solve this, it did not for me.

Other comments here on AU tell that you can enable wireless by doing:

Boot windows install the wifi drivers and the energy management solution from lenovo and enable WIFI there.

As i wiped the WIN8 installation i cannot tell if that works, too.

protected by Community Dec 28 '14 at 17:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.