19

I'm very new to Ubuntu. I have just installed it on my pc and i liked it. But as i'm from Windows background i like the taskbar at the bottom and not at the left position. So is there any way to move it to bottom position? I searched on the net and found a solution but it is for 32 bit version 11.10 and i'm using version 14.04 LTS the latest one on 64 bit machine. Thanks for your kind help.

  • Hmm... seems like you asking separate things... are you talking about the launcher at the left side? Or the panel at the top of the screen? – ElefantPhace Aug 6 '14 at 4:34
  • If you're wanting to move the launcher to the bottom, there's no official support for that since 12.04. But there are third-party workarounds. Look at this answer, and there is also a search function on this site as well as using google itself – ElefantPhace Aug 6 '14 at 4:40
  • @ElefantPhace:- I'm asking about the launcher which is at the left position as I mentioned in my question. – Rolen Koh Aug 6 '14 at 4:44
  • ok... well then read my comment above and proceed as you wish – ElefantPhace Aug 6 '14 at 4:49
  • 1
    Upgrade to 16.04 , that feature is available in 16.04 but not in 14.04 – Sergiy Kolodyazhnyy Sep 10 '16 at 4:47
13

I know this question is for 14.04, but as this is one of the first results for "moving taksbar to bottom", I think it will be helpful to others like me who want to do this on Ubuntu 16.04:

Just execute the following command:

gsettings set com.canonical.Unity.Launcher launcher-position Bottom

Or, if you prefer something more detailed, and more options, install unity tweak tool, as explained in the accepted answer.

  • 5
    no such key 'launcher position in 14.04 – salih kallai Nov 15 '16 at 10:51
  • 1
    This is it. This is what you should use with 16.04+. It also works on 17 – Gaspa79 Jul 17 '17 at 14:29
9

In case you want to use unity you can achieve similar thing:

  1. Install unity-tweak-tool:

    sudo apt-get install unity-tweak-tool
    
  2. Run unity-tweak-tool and in Launcher choose autohide.

  3. Install cairo-dock using:

    sudo apt-get install cairo-dock
    
  4. Run cairo-dock and add the applications in the dock you wanna use.

In case you wanna use gnome you can use gnome-session-flashback and delete the taskbar above and you can achieve desired functionality:

sudo apt-get install gnome-session-flashback

You can refer complete tutorial on:

http://www.webupd8.org/2014/04/how-to-install-and-tweak-gnome.html

  • 1
    This adds a Mac OS-like task bar at the bottom, but also keeps the Unity system tray thing (it doesn't show any tasks) at the top. The taskbar is such a basic and fundamental UI element for any OS. I'm amazed at how impossible it is to configure it in Unity vs. cough Windows. – Dan Dascalescu Mar 9 '16 at 1:38
2

I assume you are using the main edition of Ubuntu 14.04 x64. Unfortunately the desktop environment of main edition called Unity lacks any ability of customization - you can't move anything.

You can try installing other desktop environments such as Xfce. You can read how to install Xfce in your Ubuntu 14.04 in this site. In Xfce you can move "panels" (taskbars) to either top or bottom of the screen and you can also customize the contents (applets) of the taskbar.

2

If you're using XFCE, you simply right click the panel -> Panel preferences. Then drag it whereever you like. Like so:

Move that taskbar

0
  • Go to ‘System Settings > Appearance’
  • Select the ‘Behavior’ tab
  • Find the section headed: ‘Show the Menus for a Window’
  • Check (click) the circle next to ‘In the window’s title bar’
  • 1
    This most definitely does not answer the question, but I still like this change too! Thanks for the tip! – Gabriel Staples Dec 13 '17 at 4:52
-1

if you click on panel preferences (right click), you can move the panel whilst in this mode (on my computer it is highlighted with a red dashed border). The icons don't line up but its better then before. You also delete the panel, by using the plus or minus on the panel preferences pane.

  • 1
    Context: This is only available on XFCE, not the default Ubuntu Desktop. – neojp Aug 31 '17 at 2:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.