25

So a couple of weeks ago my network manager icon stopped appearing; I still get automatically connected to my saved networks and the internet works fine, etc. If I go into System Settings and look at the Network settings I can still see all the networks, only the icon that's normal in the top bar is missing.

I have no idea what caused this, I don't remember installing anything. I think it just happened after a regular update.

I tried these commands to make sure I was properly up-to-date, (which I found on another forum post):

sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade

That didn't do it so I found this post: Network manager indicator missing and I followed the instructions in those answers:

sudo apt-get purge network-manager-gnome && \
sudo apt-get install network-manager-gnome

And, quoted from an answer there:

Add nm-applet to the Startup Applications (which may be found by entering "Startup Applications" in the Dash).

I restarted and then saw no Unity interface at all! So I tried those 3 commands above to update again and thankfully that fixed Unity but I still don't have my network manager.

If I try the command nm-applet in a terminal it says:

nm-applet-Message: using fallback from indicator to GtkStatusIcon

So.... I'm pretty much stumped. Any help would be appreciated.

3
  • 2
    This has been an extremely annoying issue and, although I see a handful of other occurrences reported around the net, no one seems to have a good solution. I'm on the verge of doing a clean reinstall of Ubuntu over this. That's a lot of my time to backup what I need, reinstall, and then reinstall all of the apps and packages I use. Is there no way to repair this issue?
    – Kenmore
    Commented Aug 25, 2014 at 1:27
  • These two might help: askubuntu.com/questions/364219/… askubuntu.com/questions/138196/… Commented Sep 9, 2014 at 17:26
  • I did a sudo apt-get install network-manager-gnome, and after killall nm-applet; nm-applet & the icon came back. Commented May 30, 2017 at 13:48

5 Answers 5

13

I was able to fix it by changing nm-applet to launch with dbus-launch nm-applet. To see if this will work for you, try running dbus-launch nm-applet and see if that shows up properly. To make the fix permanent, I edited /etc/xdg/autostart/nm-applet.desktop and changed

Exec=nm-applet

to

Exec=dbus-launch nm-applet
5
  • Unrelated, but my battery indicator actually ended up disappearing too... no idea why. But, because of these issues and wanting to make my Ubuntu partition much bigger, I reinstalled. (I almost never use Windows on my laptop anymore :) ) I am accepting this answer in case in helps anyone in the future, but note, I never got the chance to try it.
    – Kenmore
    Commented Dec 12, 2014 at 0:44
  • If this is not working Try adding the dbus-launch nm-applet command as startup application. Go to Startup Applications and try add dbus-launch nm-applet command as new one. That will fixed the issue. +1 for the Answer. Commented Dec 22, 2014 at 7:49
  • Nope, didn't work at all under Gnome-Shell. Received same GtkStatusIcon error.
    – Cerin
    Commented Jan 3, 2015 at 2:51
  • 2
    Error coming when I tried to test. dbus-launch nm-applet Unable to create /home/satya/.dbus/session-bus Couldn't exec nm-applet: No such file or directory Commented Apr 13, 2017 at 15:38
  • not worked for me. i restarted system too. Commented Feb 15, 2018 at 9:08
9

This fixed it for me

sudo apt-get install indicator-applet-complete
4
  • This method worked for me after reboot on ubuntu 15.04 Commented May 18, 2015 at 10:06
  • This worked for me after first uninstalling indiactor-applet-complete, then running this command
    – Matt
    Commented Jul 2, 2015 at 11:43
  • 3
    Not worked for me. I restarted the system too. Commented Apr 13, 2017 at 15:36
  • 1
    not worked for me. i restarted system too. Commented Feb 15, 2018 at 9:08
3

I also face the same issue network icon is not coming in top bar SO just do the same Open the terminal (CTRL+ALT+T) and install and reinstall the network-manager with the following command:

sudo apt-get install --reinstall network-manager network-manager-gnome

reboot

nohup nm-applet &
1
  • +1 This solved my problem permanently on my Ubuntu 18.04
    – jav
    Commented May 7, 2021 at 19:07
0

I changed the file in ~/.config/autostart/nm-applet.desktop

To this

[Desktop Entry]
Name=Network
Comment=Manage your network connections (MATE)
Icon=nm-device-wireless
Exec=dbus-launch nm-applet
Terminal=false
Type=Application
NoDisplay=false
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=NetworkManager
X-GNOME-Bugzilla-Component=nm-applet
X-GNOME-UsesNotifications=true
X-Ubuntu-Gettext-Domain=nm-applet
Hidden=false

Now it shows in Ubuntu MATE 16.04

0

I had the same issue for a while. I tried sudo apt-get install indicator-applet-complete and this did not work. Tried purging and reinstalling gnome network manager which also did not work. Checked through my startup programs and nothing in there was out of place. I tried adding it from the menu on the toolbar and was able to add a network monitor applet but no network indicator that I desired. Turned out to be a simple fix

System > Preferences > Look & Feel > Mate Tweak

Selected the 'Traditional' Layout instead of whatever had come with the install and all was well. CAUTION: this will wipe existing applets, so if you have any that you are particularly fond of you will want to back them up. I suggest saving your current layout prior to changing.

If you don't have Mate Tweak then:

sudo add-apt-repository ppa:ubuntu-mate-dev/trusty-mate

sudo apt-get update

sudo apt-get install mate-tweak

or https://launchpad.net/ubuntu/+source/mate-tweak for a package.

Hope this helps someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .